2003-05-30 09:19:57

by Pascal Schmidt

[permalink] [raw]
Subject: Re: capability flag for ATAPI MO (from kernel mailing list)

On Fri, 30 May 2003, David Wilson wrote:

> Is optical (or CDC_OPTICAL) a good name for this capability?
> After all, CD CD-R CD-RW DVD DVD+/-R(W) are all optical.

Well, I simply used something similar to ide_optical from IDE code, but
I agree that it's not optimal.

> That said, a better name does not immediately spring to mind
> (unless MOPTICAL works for you - magneto-optical seems too long).

I'll see what Jens has to say about the name. CDC_MOPTICAL looks ugly
to me, and CDC_MO too short. Maybe CDC_MO_DRIVE would work if
CDC_OPTICAL is not acceptable.

--
Ciao,
Pascal


2003-06-02 10:32:03

by Jens Axboe

[permalink] [raw]
Subject: Re: capability flag for ATAPI MO (from kernel mailing list)

On Fri, May 30 2003, Pascal Schmidt wrote:
> On Fri, 30 May 2003, David Wilson wrote:
>
> > Is optical (or CDC_OPTICAL) a good name for this capability?
> > After all, CD CD-R CD-RW DVD DVD+/-R(W) are all optical.
>
> Well, I simply used something similar to ide_optical from IDE code, but
> I agree that it's not optimal.
>
> > That said, a better name does not immediately spring to mind
> > (unless MOPTICAL works for you - magneto-optical seems too long).
>
> I'll see what Jens has to say about the name. CDC_MOPTICAL looks ugly
> to me, and CDC_MO too short. Maybe CDC_MO_DRIVE would work if
> CDC_OPTICAL is not acceptable.

CDC_MO_DRIVE would be fine with me, it's right to the point. But
basically I don't really care, I think it's pretty clear even if named
CDC_OPTICAL.

--
Jens Axboe