2021-09-26 13:09:10

by Christophe JAILLET

[permalink] [raw]
Subject: [PATCH] iommu/tegra-smmu: Use devm_bitmap_zalloc when applicable

'smmu->asids' is a bitmap. So use 'devm_kzalloc()' to simplify code,
improve the semantic of the code and avoid some open-coded arithmetic in
allocator arguments.

Signed-off-by: Christophe JAILLET <[email protected]>
---
drivers/iommu/tegra-smmu.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/iommu/tegra-smmu.c b/drivers/iommu/tegra-smmu.c
index 0a281833f611..e900e3c46903 100644
--- a/drivers/iommu/tegra-smmu.c
+++ b/drivers/iommu/tegra-smmu.c
@@ -1079,7 +1079,6 @@ struct tegra_smmu *tegra_smmu_probe(struct device *dev,
struct tegra_mc *mc)
{
struct tegra_smmu *smmu;
- size_t size;
u32 value;
int err;

@@ -1097,9 +1096,7 @@ struct tegra_smmu *tegra_smmu_probe(struct device *dev,
*/
mc->smmu = smmu;

- size = BITS_TO_LONGS(soc->num_asids) * sizeof(long);
-
- smmu->asids = devm_kzalloc(dev, size, GFP_KERNEL);
+ smmu->asids = devm_bitmap_zalloc(dev, soc->num_asids, GFP_KERNEL);
if (!smmu->asids)
return ERR_PTR(-ENOMEM);

--
2.30.2


2021-10-07 20:51:03

by Thierry Reding

[permalink] [raw]
Subject: Re: [PATCH] iommu/tegra-smmu: Use devm_bitmap_zalloc when applicable

On Sun, Sep 26, 2021 at 03:07:18PM +0200, Christophe JAILLET wrote:
> 'smmu->asids' is a bitmap. So use 'devm_kzalloc()' to simplify code,
> improve the semantic of the code and avoid some open-coded arithmetic in
> allocator arguments.
>
> Signed-off-by: Christophe JAILLET <[email protected]>
> ---
> drivers/iommu/tegra-smmu.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)

Acked-by: Thierry Reding <[email protected]>


Attachments:
(No filename) (462.00 B)
signature.asc (849.00 B)
Download all attachments

2021-10-18 11:42:10

by Joerg Roedel

[permalink] [raw]
Subject: Re: [PATCH] iommu/tegra-smmu: Use devm_bitmap_zalloc when applicable

On Sun, Sep 26, 2021 at 03:07:18PM +0200, Christophe JAILLET wrote:
> 'smmu->asids' is a bitmap. So use 'devm_kzalloc()' to simplify code,
> improve the semantic of the code and avoid some open-coded arithmetic in
> allocator arguments.
>
> Signed-off-by: Christophe JAILLET <[email protected]>
> ---
> drivers/iommu/tegra-smmu.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)

Applied, thanks.