2021-12-02 20:16:21

by Christophe JAILLET

[permalink] [raw]
Subject: [PATCH v2] xen-blkfront: Use the bitmap API when applicable

Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
open-coded arithmetic in allocator arguments.

Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
consistency.

Use 'bitmap_copy()' to avoid an explicit 'memcpy()'

Signed-off-by: Christophe JAILLET <[email protected]>
---
v1 --> v2: change another kfree into bitmap_free
---
drivers/block/xen-blkfront.c | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/drivers/block/xen-blkfront.c b/drivers/block/xen-blkfront.c
index 700c765a759a..69cf13608ce0 100644
--- a/drivers/block/xen-blkfront.c
+++ b/drivers/block/xen-blkfront.c
@@ -442,22 +442,20 @@ static int xlbd_reserve_minors(unsigned int minor, unsigned int nr)
if (end > nr_minors) {
unsigned long *bitmap, *old;

- bitmap = kcalloc(BITS_TO_LONGS(end), sizeof(*bitmap),
- GFP_KERNEL);
+ bitmap = bitmap_zalloc(end, GFP_KERNEL);
if (bitmap == NULL)
return -ENOMEM;

spin_lock(&minor_lock);
if (end > nr_minors) {
old = minors;
- memcpy(bitmap, minors,
- BITS_TO_LONGS(nr_minors) * sizeof(*bitmap));
+ bitmap_copy(bitmap, minors, nr_minors);
minors = bitmap;
nr_minors = BITS_TO_LONGS(end) * BITS_PER_LONG;
} else
old = bitmap;
spin_unlock(&minor_lock);
- kfree(old);
+ bitmap_free(old);
}

spin_lock(&minor_lock);
@@ -2610,7 +2608,7 @@ static void __exit xlblk_exit(void)

xenbus_unregister_driver(&blkfront_driver);
unregister_blkdev(XENVBD_MAJOR, DEV_NAME);
- kfree(minors);
+ bitmap_free(minors);
}
module_exit(xlblk_exit);

--
2.30.2



2021-12-14 11:07:00

by Roger Pau Monne

[permalink] [raw]
Subject: Re: [PATCH v2] xen-blkfront: Use the bitmap API when applicable

On Thu, Dec 02, 2021 at 09:16:04PM +0100, Christophe JAILLET wrote:
> Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
> open-coded arithmetic in allocator arguments.
>
> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> consistency.
>
> Use 'bitmap_copy()' to avoid an explicit 'memcpy()'
>
> Signed-off-by: Christophe JAILLET <[email protected]>

Acked-by: Roger Pau Monné <[email protected]>

Thanks, Roger.

2021-12-14 11:08:39

by Roger Pau Monne

[permalink] [raw]
Subject: Re: [PATCH v2] xen-blkfront: Use the bitmap API when applicable

On Tue, Dec 14, 2021 at 11:59:39AM +0100, Roger Pau Monné wrote:
> On Thu, Dec 02, 2021 at 09:16:04PM +0100, Christophe JAILLET wrote:
> > Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
> > open-coded arithmetic in allocator arguments.
> >
> > Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
> > consistency.
> >
> > Use 'bitmap_copy()' to avoid an explicit 'memcpy()'
> >
> > Signed-off-by: Christophe JAILLET <[email protected]>
>
> Acked-by: Roger Pau Monné <[email protected]>

Oh, I see there's been further discussion on this to avoid relying
implicitly on the size of the bitmap being rounded to the size of an
unsigned long. I think a new version is expected then?

Thanks, Roger.

2021-12-14 17:57:56

by Christophe JAILLET

[permalink] [raw]
Subject: Re: [PATCH v2] xen-blkfront: Use the bitmap API when applicable

Le 14/12/2021 à 12:08, Roger Pau Monné a écrit :
> On Tue, Dec 14, 2021 at 11:59:39AM +0100, Roger Pau Monné wrote:
>> On Thu, Dec 02, 2021 at 09:16:04PM +0100, Christophe JAILLET wrote:
>>> Use 'bitmap_zalloc()' to simplify code, improve the semantic and avoid some
>>> open-coded arithmetic in allocator arguments.
>>>
>>> Also change the corresponding 'kfree()' into 'bitmap_free()' to keep
>>> consistency.
>>>
>>> Use 'bitmap_copy()' to avoid an explicit 'memcpy()'
>>>
>>> Signed-off-by: Christophe JAILLET <[email protected]>
>>
>> Acked-by: Roger Pau Monné <[email protected]>
>
> Oh, I see there's been further discussion on this to avoid relying
> implicitly on the size of the bitmap being rounded to the size of an
> unsigned long. I think a new version is expected then?
>
> Thanks, Roger.
>

Yes, I'll send a patch in order to add a 'bitmap_size()'
I'll update this patch when/if it is merged.

You can drop it for now.

CJ