1. Enhance generic ioremap to make it more useful.
2. Let's arm64 use GENERIC_IOREMAP to cleanup code.
3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(),
it is useful when debug(eg, gdb) via access_process_vm device memory
infrastructure.
v2:
- s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton
- rename arch_ioremap/iounmap_check to arch_ioremap/iounmad
and change return value, per Christoph Hellwig and Andrew Morton
- and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann
- collect ack/review
Kefeng Wang (5):
mm: ioremap: Use more sensibly name in ioremap_prot()
mm: ioremap: Setup phys_addr of struct vm_struct
mm: ioremap: Add arch_ioremap/iounmap()
arm64: mm: Convert to GENERIC_IOREMAP
arm64: Add HAVE_IOREMAP_PROT support
.../features/vm/ioremap_prot/arch-support.txt | 2 +-
arch/arm64/Kconfig | 2 +
arch/arm64/include/asm/io.h | 20 +++--
arch/arm64/include/asm/pgtable.h | 10 +++
arch/arm64/kernel/acpi.c | 2 +-
arch/arm64/mm/hugetlbpage.c | 10 ---
arch/arm64/mm/ioremap.c | 85 +++----------------
include/asm-generic/io.h | 16 +++-
mm/ioremap.c | 27 ++++--
9 files changed, 74 insertions(+), 100 deletions(-)
--
2.35.3
Use more meaningful and sensibly naming phys_addr
instead addr in ioremap_prot().
Suggested-by: Andrew Morton <[email protected]>
Signed-off-by: Kefeng Wang <[email protected]>
---
include/asm-generic/io.h | 2 +-
mm/ioremap.c | 12 ++++++------
2 files changed, 7 insertions(+), 7 deletions(-)
diff --git a/include/asm-generic/io.h b/include/asm-generic/io.h
index 7ce93aaf69f8..e6ffa2519f08 100644
--- a/include/asm-generic/io.h
+++ b/include/asm-generic/io.h
@@ -964,7 +964,7 @@ static inline void iounmap(volatile void __iomem *addr)
#elif defined(CONFIG_GENERIC_IOREMAP)
#include <linux/pgtable.h>
-void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot);
+void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long prot);
void iounmap(volatile void __iomem *addr);
static inline void __iomem *ioremap(phys_addr_t addr, size_t size)
diff --git a/mm/ioremap.c b/mm/ioremap.c
index 5fe598ecd9b7..1f9597fbcc07 100644
--- a/mm/ioremap.c
+++ b/mm/ioremap.c
@@ -11,20 +11,20 @@
#include <linux/io.h>
#include <linux/export.h>
-void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot)
+void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long prot)
{
unsigned long offset, vaddr;
phys_addr_t last_addr;
struct vm_struct *area;
/* Disallow wrap-around or zero size */
- last_addr = addr + size - 1;
- if (!size || last_addr < addr)
+ last_addr = phys_addr + size - 1;
+ if (!size || last_addr < phys_addr)
return NULL;
/* Page-align mappings */
- offset = addr & (~PAGE_MASK);
- addr -= offset;
+ offset = phys_addr & (~PAGE_MASK);
+ phys_addr -= offset;
size = PAGE_ALIGN(size + offset);
area = get_vm_area_caller(size, VM_IOREMAP,
@@ -33,7 +33,7 @@ void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot)
return NULL;
vaddr = (unsigned long)area->addr;
- if (ioremap_page_range(vaddr, vaddr + size, addr, __pgprot(prot))) {
+ if (ioremap_page_range(vaddr, vaddr + size, phys_addr, __pgprot(prot))) {
free_vm_area(area);
return NULL;
}
--
2.35.3
Show physical address of each ioremap in /proc/vmallocinfo.
Acked-by: Andrew Morton <[email protected]>
Reviewed-by: Christoph Hellwig <[email protected]>
Signed-off-by: Kefeng Wang <[email protected]>
---
mm/ioremap.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/mm/ioremap.c b/mm/ioremap.c
index 1f9597fbcc07..7cb9996b0c12 100644
--- a/mm/ioremap.c
+++ b/mm/ioremap.c
@@ -32,6 +32,7 @@ void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long pro
if (!area)
return NULL;
vaddr = (unsigned long)area->addr;
+ area->phys_addr = phys_addr;
if (ioremap_page_range(vaddr, vaddr + size, phys_addr, __pgprot(prot))) {
free_vm_area(area);
--
2.35.3
On 4/29/22 16:02, Kefeng Wang wrote:
> Show physical address of each ioremap in /proc/vmallocinfo.
>
> Acked-by: Andrew Morton <[email protected]>
> Reviewed-by: Christoph Hellwig <[email protected]>
> Signed-off-by: Kefeng Wang <[email protected]>
Reviewed-by: Anshuman Khandual <[email protected]>
> ---
> mm/ioremap.c | 1 +
> 1 file changed, 1 insertion(+)
>
> diff --git a/mm/ioremap.c b/mm/ioremap.c
> index 1f9597fbcc07..7cb9996b0c12 100644
> --- a/mm/ioremap.c
> +++ b/mm/ioremap.c
> @@ -32,6 +32,7 @@ void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long pro
> if (!area)
> return NULL;
> vaddr = (unsigned long)area->addr;
> + area->phys_addr = phys_addr;
>
> if (ioremap_page_range(vaddr, vaddr + size, phys_addr, __pgprot(prot))) {
> free_vm_area(area);
On 4/29/22 16:02, Kefeng Wang wrote:
> Use more meaningful and sensibly naming phys_addr
> instead addr in ioremap_prot().
>
> Suggested-by: Andrew Morton <[email protected]>
> Signed-off-by: Kefeng Wang <[email protected]>
Reviewed-by: Anshuman Khandual <[email protected]>
> ---
> include/asm-generic/io.h | 2 +-
> mm/ioremap.c | 12 ++++++------
> 2 files changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/include/asm-generic/io.h b/include/asm-generic/io.h
> index 7ce93aaf69f8..e6ffa2519f08 100644
> --- a/include/asm-generic/io.h
> +++ b/include/asm-generic/io.h
> @@ -964,7 +964,7 @@ static inline void iounmap(volatile void __iomem *addr)
> #elif defined(CONFIG_GENERIC_IOREMAP)
> #include <linux/pgtable.h>
>
> -void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot);
> +void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long prot);
> void iounmap(volatile void __iomem *addr);
>
> static inline void __iomem *ioremap(phys_addr_t addr, size_t size)
> diff --git a/mm/ioremap.c b/mm/ioremap.c
> index 5fe598ecd9b7..1f9597fbcc07 100644
> --- a/mm/ioremap.c
> +++ b/mm/ioremap.c
> @@ -11,20 +11,20 @@
> #include <linux/io.h>
> #include <linux/export.h>
>
> -void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot)
> +void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size, unsigned long prot)
> {
> unsigned long offset, vaddr;
> phys_addr_t last_addr;
> struct vm_struct *area;
>
> /* Disallow wrap-around or zero size */
> - last_addr = addr + size - 1;
> - if (!size || last_addr < addr)
> + last_addr = phys_addr + size - 1;
> + if (!size || last_addr < phys_addr)
> return NULL;
>
> /* Page-align mappings */
> - offset = addr & (~PAGE_MASK);
> - addr -= offset;
> + offset = phys_addr & (~PAGE_MASK);
> + phys_addr -= offset;
> size = PAGE_ALIGN(size + offset);
>
> area = get_vm_area_caller(size, VM_IOREMAP,
> @@ -33,7 +33,7 @@ void __iomem *ioremap_prot(phys_addr_t addr, size_t size, unsigned long prot)
> return NULL;
> vaddr = (unsigned long)area->addr;
>
> - if (ioremap_page_range(vaddr, vaddr + size, addr, __pgprot(prot))) {
> + if (ioremap_page_range(vaddr, vaddr + size, phys_addr, __pgprot(prot))) {
> free_vm_area(area);
> return NULL;
> }
Hello maintainers,kindly ping.
On 2022/4/29 18:32, Kefeng Wang wrote:
> 1. Enhance generic ioremap to make it more useful.
> 2. Let's arm64 use GENERIC_IOREMAP to cleanup code.
> 3. Support HAVE_IOREMAP_PROT on arm64, which enable generic_access_phys(),
> it is useful when debug(eg, gdb) via access_process_vm device memory
> infrastructure.
>
> v2:
> - s/addr/phys_addr in ioremap_prot, suggested by Andrew Morton
> - rename arch_ioremap/iounmap_check to arch_ioremap/iounmad
> and change return value, per Christoph Hellwig and Andrew Morton
> - and use 'ifndef arch_ioremap' instead of weak function, per Arnd Bergmann
> - collect ack/review
>
> Kefeng Wang (5):
> mm: ioremap: Use more sensibly name in ioremap_prot()
> mm: ioremap: Setup phys_addr of struct vm_struct
> mm: ioremap: Add arch_ioremap/iounmap()
> arm64: mm: Convert to GENERIC_IOREMAP
> arm64: Add HAVE_IOREMAP_PROT support
>
> .../features/vm/ioremap_prot/arch-support.txt | 2 +-
> arch/arm64/Kconfig | 2 +
> arch/arm64/include/asm/io.h | 20 +++--
> arch/arm64/include/asm/pgtable.h | 10 +++
> arch/arm64/kernel/acpi.c | 2 +-
> arch/arm64/mm/hugetlbpage.c | 10 ---
> arch/arm64/mm/ioremap.c | 85 +++----------------
> include/asm-generic/io.h | 16 +++-
> mm/ioremap.c | 27 ++++--
> 9 files changed, 74 insertions(+), 100 deletions(-)
>
On Fri, Apr 29, 2022 at 06:32:20PM +0800, Kefeng Wang wrote:
> Kefeng Wang (5):
> mm: ioremap: Use more sensibly name in ioremap_prot()
> mm: ioremap: Setup phys_addr of struct vm_struct
> mm: ioremap: Add arch_ioremap/iounmap()
> arm64: mm: Convert to GENERIC_IOREMAP
> arm64: Add HAVE_IOREMAP_PROT support
>
> .../features/vm/ioremap_prot/arch-support.txt | 2 +-
> arch/arm64/Kconfig | 2 +
> arch/arm64/include/asm/io.h | 20 +++--
> arch/arm64/include/asm/pgtable.h | 10 +++
> arch/arm64/kernel/acpi.c | 2 +-
> arch/arm64/mm/hugetlbpage.c | 10 ---
> arch/arm64/mm/ioremap.c | 85 +++----------------
> include/asm-generic/io.h | 16 +++-
> mm/ioremap.c | 27 ++++--
> 9 files changed, 74 insertions(+), 100 deletions(-)
These patches touch the generic mm parts. Andrew, would you like to
merge these patches or are happy for them to go via the arm64 tree.
Thanks.
--
Catalin
On 2022/5/17 6:51, Catalin Marinas wrote:
> On Fri, Apr 29, 2022 at 06:32:20PM +0800, Kefeng Wang wrote:
>> Kefeng Wang (5):
>> mm: ioremap: Use more sensibly name in ioremap_prot()
>> mm: ioremap: Setup phys_addr of struct vm_struct
>> mm: ioremap: Add arch_ioremap/iounmap()
>> arm64: mm: Convert to GENERIC_IOREMAP
>> arm64: Add HAVE_IOREMAP_PROT support
>>
>> .../features/vm/ioremap_prot/arch-support.txt | 2 +-
>> arch/arm64/Kconfig | 2 +
>> arch/arm64/include/asm/io.h | 20 +++--
>> arch/arm64/include/asm/pgtable.h | 10 +++
>> arch/arm64/kernel/acpi.c | 2 +-
>> arch/arm64/mm/hugetlbpage.c | 10 ---
>> arch/arm64/mm/ioremap.c | 85 +++----------------
>> include/asm-generic/io.h | 16 +++-
>> mm/ioremap.c | 27 ++++--
>> 9 files changed, 74 insertions(+), 100 deletions(-)
> These patches touch the generic mm parts. Andrew, would you like to
> merge these patches or are happy for them to go via the arm64 tree.
Hi Andrew, what's your preference ;)
> Thanks.
>