2024-04-29 07:27:08

by zhang warden

[permalink] [raw]
Subject: [PATCH] livepatch.h: Add comment to klp transition state

From: Wardenjohn <[email protected]>

livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
In order not to introduce potential risks to kernel, just update comment
to these state.
---
include/linux/livepatch.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
index 9b9b38e89563..b6a214f2f8e3 100644
--- a/include/linux/livepatch.h
+++ b/include/linux/livepatch.h
@@ -18,9 +18,9 @@
#if IS_ENABLED(CONFIG_LIVEPATCH)

/* task patch states */
-#define KLP_UNDEFINED -1
-#define KLP_UNPATCHED 0
-#define KLP_PATCHED 1
+#define KLP_UNDEFINED -1 /* idle, no transition in progress */
+#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
+#define KLP_PATCHED 1 /* transitioning to patched state */

/**
* struct klp_func - function structure for live patching
--
2.37.3



2024-05-05 21:00:36

by Josh Poimboeuf

[permalink] [raw]
Subject: Re: [PATCH] livepatch.h: Add comment to klp transition state

On Mon, Apr 29, 2024 at 03:26:28PM +0800, [email protected] wrote:
> From: Wardenjohn <[email protected]>
>
> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
> When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
> In order not to introduce potential risks to kernel, just update comment
> to these state.
> ---
> include/linux/livepatch.h | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
> index 9b9b38e89563..b6a214f2f8e3 100644
> --- a/include/linux/livepatch.h
> +++ b/include/linux/livepatch.h
> @@ -18,9 +18,9 @@
> #if IS_ENABLED(CONFIG_LIVEPATCH)
>
> /* task patch states */
> -#define KLP_UNDEFINED -1
> -#define KLP_UNPATCHED 0
> -#define KLP_PATCHED 1
> +#define KLP_UNDEFINED -1 /* idle, no transition in progress */
> +#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
> +#define KLP_PATCHED 1 /* transitioning to patched state */

Instead of the comments, how about we just rename them to

KLP_TRANSITION_IDLE
KLP_TRANSITION_UNPATCHED
KLP_TRANSITION_PATCHED

which shouldn't break userspace AFAIK.

--
Josh

2024-05-06 02:04:51

by zhang warden

[permalink] [raw]
Subject: Re: [PATCH] livepatch.h: Add comment to klp transition state



> On May 6, 2024, at 05:00, Josh Poimboeuf <[email protected]> wrote:
>
> On Mon, Apr 29, 2024 at 03:26:28PM +0800, [email protected] wrote:
>> From: Wardenjohn <[email protected]>
>>
>> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
>> When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
>> In order not to introduce potential risks to kernel, just update comment
>> to these state.
>> ---
>> include/linux/livepatch.h | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
>> index 9b9b38e89563..b6a214f2f8e3 100644
>> --- a/include/linux/livepatch.h
>> +++ b/include/linux/livepatch.h
>> @@ -18,9 +18,9 @@
>> #if IS_ENABLED(CONFIG_LIVEPATCH)
>>
>> /* task patch states */
>> -#define KLP_UNDEFINED -1
>> -#define KLP_UNPATCHED 0
>> -#define KLP_PATCHED 1
>> +#define KLP_UNDEFINED -1 /* idle, no transition in progress */
>> +#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
>> +#define KLP_PATCHED 1 /* transitioning to patched state */
>
> Instead of the comments, how about we just rename them to
>
> KLP_TRANSITION_IDLE
> KLP_TRANSITION_UNPATCHED
> KLP_TRANSITION_PATCHED
>
> which shouldn't break userspace AFAIK.
>
> --
> Josh

Hi Josh!

Renaming them may be a better way as my previous patch. I would like to know why renaming KLP_*** into
KLP_TRANSITION_*** will not break userspace while
Renaming KLP_UNDEWFINED to KLP_IDLE would break the userspace.

Meanwhile, I will resubmit another patch renaming the macros as your suggestion ASAP. Thank ~~ :)

--
Wardenjohn


2024-05-06 08:38:04

by Petr Mladek

[permalink] [raw]
Subject: Re: [PATCH] livepatch.h: Add comment to klp transition state

On Mon 2024-05-06 10:04:26, zhang warden wrote:
>
>
> > On May 6, 2024, at 05:00, Josh Poimboeuf <[email protected]> wrote:
> >
> > On Mon, Apr 29, 2024 at 03:26:28PM +0800, [email protected] wrote:
> >> From: Wardenjohn <[email protected]>
> >>
> >> livepatch.h use KLP_UNDEFINED\KLP_UNPATCHED\KLP_PATCHED for klp transition state.
> >> When livepatch is ready but idle, using KLP_UNDEFINED seems very confusing.
> >> In order not to introduce potential risks to kernel, just update comment
> >> to these state.
> >> ---
> >> include/linux/livepatch.h | 6 +++---
> >> 1 file changed, 3 insertions(+), 3 deletions(-)
> >>
> >> diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h
> >> index 9b9b38e89563..b6a214f2f8e3 100644
> >> --- a/include/linux/livepatch.h
> >> +++ b/include/linux/livepatch.h
> >> @@ -18,9 +18,9 @@
> >> #if IS_ENABLED(CONFIG_LIVEPATCH)
> >>
> >> /* task patch states */
> >> -#define KLP_UNDEFINED -1
> >> -#define KLP_UNPATCHED 0
> >> -#define KLP_PATCHED 1
> >> +#define KLP_UNDEFINED -1 /* idle, no transition in progress */
> >> +#define KLP_UNPATCHED 0 /* transitioning to unpatched state */
> >> +#define KLP_PATCHED 1 /* transitioning to patched state */
> >
> > Instead of the comments, how about we just rename them to
> >
> > KLP_TRANSITION_IDLE
> > KLP_TRANSITION_UNPATCHED
> > KLP_TRANSITION_PATCHED
> >
> > which shouldn't break userspace AFAIK.

Great idea! It is better then nothing.

> Renaming them may be a better way as my previous patch. I would like to know why renaming KLP_*** into
> KLP_TRANSITION_*** will not break userspace while
> Renaming KLP_UNDEWFINED to KLP_IDLE would break the userspace.

As I already wrote in [1], both "task->patch_state == KLP_UNDEFINED"
and "KLP_IDLE" are misleading. They are not talking
about the state of the patch but about the state of the transition.

We could not rename the variables because it would break userspace.
But we could rename the state names at least.

[1] https://lore.kernel.org/r/Zg7EpZol5jB_gHH9@alley

Best Regards,
Petr