2008-08-05 22:38:41

by Robert P. J. Day

[permalink] [raw]
Subject: [PATCH] Correct comment in identify_ramdisk_image() routine.


Correct the comment to reflect that a gzipped image will return zero,
not -1.

Signed-off-by: Robert P. J. Day <[email protected]>

---

the code is correct, it's only the comment that's wrong.

diff --git a/init/do_mounts_rd.c b/init/do_mounts_rd.c
index fedef93..a7c748f 100644
--- a/init/do_mounts_rd.c
+++ b/init/do_mounts_rd.c
@@ -71,7 +71,7 @@ identify_ramdisk_image(int fd, int start_block)
sys_read(fd, buf, size);

/*
- * If it matches the gzip magic numbers, return -1
+ * If it matches the gzip magic numbers, return 0
*/
if (buf[0] == 037 && ((buf[1] == 0213) || (buf[1] == 0236))) {
printk(KERN_NOTICE


========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry:
Have classroom, will lecture.

http://crashcourse.ca Waterloo, Ontario, CANADA
========================================================================