2024-03-20 21:15:03

by Ayush Tiwari

[permalink] [raw]
Subject: [PATCH v3 0/3] Trivial code cleanup patches

Address different kinds of checkpatch complains for the rtl8712 module
to ensure adherence to coding style guidelines.

Changes in v3: Fixed issues about backupPMKIDList and verified with
CONFIG_WERROR set and built the kernel.

Changes in v2: Checked any possible reuse of backup_PMKID_list
manually and rebuilt, rebooted the kernel and loaded the driver
with modprobe.

Ayush Tiwari (3):
staging: rtl8712: rename backupPMKIDList to backup_PMKID_list
staging: rtl8712: rename backupPMKIDIndex to backup_PMKID_index
staging: rtl8712: rename backupTKIPCountermeasure to
backup_TKIP_countermeasure

drivers/staging/rtl8712/mlme_linux.c | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)

--
2.40.1



2024-03-20 21:19:35

by Ayush Tiwari

[permalink] [raw]
Subject: [PATCH v3 1/3] staging: rtl8712: rename backupPMKIDList to backup_PMKID_list

Rename backupPMKIDList to backup_PMKID_list and remove extra spaces
between RT_PMKID_LIST and backupPMKIDList to address checkpatch
warnings and match the common kernel coding style.

Signed-off-by: Ayush Tiwari <[email protected]>
---
Changes in v3: Fixed the errors in v2, built the kernel with
CONFIG_WERROR set.

Changes in v2: Checked any possible reuse of backup_PMKID_list
manually and rebuilt, rebooted the kernel and loaded the driver
with modprobe.

drivers/staging/rtl8712/mlme_linux.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8712/mlme_linux.c b/drivers/staging/rtl8712/mlme_linux.c
index b9f5104f3bf7..a009ec1a5c11 100644
--- a/drivers/staging/rtl8712/mlme_linux.c
+++ b/drivers/staging/rtl8712/mlme_linux.c
@@ -84,7 +84,7 @@ void r8712_os_indicate_connect(struct _adapter *adapter)
netif_carrier_on(adapter->pnetdev);
}

-static struct RT_PMKID_LIST backupPMKIDList[NUM_PMKID_CACHE];
+static struct RT_PMKID_LIST backup_PMKID_list[NUM_PMKID_CACHE];
void r8712_os_indicate_disconnect(struct _adapter *adapter)
{
u8 backupPMKIDIndex = 0;
@@ -99,7 +99,7 @@ void r8712_os_indicate_disconnect(struct _adapter *adapter)
* disconnect with AP for 60 seconds.
*/

- memcpy(&backupPMKIDList[0],
+ memcpy(&backup_PMKID_list[0],
&adapter->securitypriv.PMKIDList[0],
sizeof(struct RT_PMKID_LIST) * NUM_PMKID_CACHE);
backupPMKIDIndex = adapter->securitypriv.PMKIDIndex;
@@ -113,7 +113,7 @@ void r8712_os_indicate_disconnect(struct _adapter *adapter)
* for the following connection.
*/
memcpy(&adapter->securitypriv.PMKIDList[0],
- &backupPMKIDList[0],
+ &backup_PMKID_list[0],
sizeof(struct RT_PMKID_LIST) * NUM_PMKID_CACHE);
adapter->securitypriv.PMKIDIndex = backupPMKIDIndex;
adapter->securitypriv.btkip_countermeasure =
--
2.40.1


2024-03-20 21:21:45

by Ayush Tiwari

[permalink] [raw]
Subject: [PATCH v3 3/3] staging: rtl8712: rename backupTKIPCountermeasure to backup_TKIP_countermeasure

Rename variable backupTKIPCountermeasure to backup_TKIP_countermeasure
to address checkpatch warning 'Avoid Camelcase' and to ensure
adherence to coding style guidelines.

Signed-off-by: Ayush Tiwari <[email protected]>
---
Changes in v3: No change

Changes in v2: No change

drivers/staging/rtl8712/mlme_linux.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/rtl8712/mlme_linux.c b/drivers/staging/rtl8712/mlme_linux.c
index ac8196d24ce0..436816d14cdf 100644
--- a/drivers/staging/rtl8712/mlme_linux.c
+++ b/drivers/staging/rtl8712/mlme_linux.c
@@ -88,7 +88,7 @@ static struct RT_PMKID_LIST backup_PMKID_list[NUM_PMKID_CACHE];
void r8712_os_indicate_disconnect(struct _adapter *adapter)
{
u8 backup_PMKID_index = 0;
- u8 backupTKIPCountermeasure = 0x00;
+ u8 backup_TKIP_countermeasure = 0x00;

r8712_indicate_wx_disassoc_event(adapter);
netif_carrier_off(adapter->pnetdev);
@@ -103,7 +103,7 @@ void r8712_os_indicate_disconnect(struct _adapter *adapter)
&adapter->securitypriv.PMKIDList[0],
sizeof(struct RT_PMKID_LIST) * NUM_PMKID_CACHE);
backup_PMKID_index = adapter->securitypriv.PMKIDIndex;
- backupTKIPCountermeasure =
+ backup_TKIP_countermeasure =
adapter->securitypriv.btkip_countermeasure;
memset((unsigned char *)&adapter->securitypriv, 0,
sizeof(struct security_priv));
@@ -117,7 +117,7 @@ void r8712_os_indicate_disconnect(struct _adapter *adapter)
sizeof(struct RT_PMKID_LIST) * NUM_PMKID_CACHE);
adapter->securitypriv.PMKIDIndex = backup_PMKID_index;
adapter->securitypriv.btkip_countermeasure =
- backupTKIPCountermeasure;
+ backup_TKIP_countermeasure;
} else { /*reset values in securitypriv*/
struct security_priv *sec_priv = &adapter->securitypriv;

--
2.40.1


2024-03-23 03:31:34

by Alison Schofield

[permalink] [raw]
Subject: Re: [PATCH v3 0/3] Trivial code cleanup patches

On Thu, Mar 21, 2024 at 02:55:07AM +0530, Ayush Tiwari wrote:
> Address different kinds of checkpatch complains for the rtl8712 module
> to ensure adherence to coding style guidelines.

Thanks for sending v3 as a new email, rather than threaded with
prior revisions.

I think you repeat the changelog in the patches, but I'll go
ahead and comment right here. It applies in the patch too.

>
> Changes in v3: Fixed issues about backupPMKIDList and verified with
> CONFIG_WERROR set and built the kernel.
>
> Changes in v2: Checked any possible reuse of backup_PMKID_list
> manually and rebuilt, rebooted the kernel and loaded the driver
> with modprobe.

The change log is to inform reviewers of what actually changed
in the patch since previous version. So let's be specific
in these v2, v3, and next a v4 changelog. I think this is
right:

v4: Update the changelog to match revision history
v3: Update memcpy() param to match new name backup_PMKID_list
v2: No changes. Just a patch sending error.

There's a section in the first patch tutorial about replying to
patch feedback and you can read any of the lore lists to see
examples. Folks will expect you to reply to their feedback.
Even if it's just a simple "Thanks, got it!" Then, they will
look to see if their feedback affected the next revision.

--Alison

>
> Ayush Tiwari (3):
> staging: rtl8712: rename backupPMKIDList to backup_PMKID_list
> staging: rtl8712: rename backupPMKIDIndex to backup_PMKID_index
> staging: rtl8712: rename backupTKIPCountermeasure to
> backup_TKIP_countermeasure
>
> drivers/staging/rtl8712/mlme_linux.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> --
> 2.40.1
>
>

2024-03-25 18:46:10

by Greg Kroah-Hartman

[permalink] [raw]
Subject: Re: [PATCH v3 0/3] Trivial code cleanup patches

On Thu, Mar 21, 2024 at 02:44:51AM +0530, Ayush Tiwari wrote:
> Address different kinds of checkpatch complains for the rtl8712 module
> to ensure adherence to coding style guidelines.
>
> Changes in v3: Fixed issues about backupPMKIDList and verified with
> CONFIG_WERROR set and built the kernel.
>
> Changes in v2: Checked any possible reuse of backup_PMKID_list
> manually and rebuilt, rebooted the kernel and loaded the driver
> with modprobe.

The subject line for this 0/3 email does not give us a hint as to what
these changes are for. Please resend the next version with something
like:
staging: rtl8712: .....

so that we know what to expect.

thanks,

greg k-h