2021-04-06 14:33:07

by Jiele Zhao

[permalink] [raw]
Subject: [PATCH v2] ima: Fix function name error in comment.

The original function name was ima_path_check(). The policy parsing
still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename
ima_path_check to ima_file_check") renamed the function to
ima_file_check(), but missed modifying the function name in the
comment.

Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").

Signed-off-by: Jiele Zhao <[email protected]>
---
security/integrity/ima/ima_main.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
index 9ef748ea829f..03bef720ab44 100644
--- a/security/integrity/ima/ima_main.c
+++ b/security/integrity/ima/ima_main.c
@@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm)
}

/**
- * ima_path_check - based on policy, collect/store measurement.
+ * ima_file_check - based on policy, collect/store measurement.
* @file: pointer to the file to be measured
* @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND
*
--
2.25.1


2021-04-09 01:23:37

by Jiele Zhao

[permalink] [raw]
Subject: Re: [PATCH v2] ima: Fix function name error in comment.

Hi Mimi,

On 2021/4/6 10:12, Jiele Zhao wrote:
> The original function name was ima_path_check(). The policy parsing
> still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename
> ima_path_check to ima_file_check") renamed the function to
> ima_file_check(), but missed modifying the function name in the
> comment.
>
> Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").
>
> Signed-off-by: Jiele Zhao <[email protected]>
> ---
> security/integrity/ima/ima_main.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
> index 9ef748ea829f..03bef720ab44 100644
> --- a/security/integrity/ima/ima_main.c
> +++ b/security/integrity/ima/ima_main.c
> @@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm)
> }
>
> /**
> - * ima_path_check - based on policy, collect/store measurement.
> + * ima_file_check - based on policy, collect/store measurement.
> * @file: pointer to the file to be measured
> * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND
> *

This is the [patch v2] based on your suggestion. Does this meet the
requirements ?


2021-04-09 18:51:10

by Mimi Zohar

[permalink] [raw]
Subject: Re: [PATCH v2] ima: Fix function name error in comment.

On Tue, 2021-04-06 at 02:12 +0000, Jiele Zhao wrote:
> The original function name was ima_path_check(). The policy parsing
> still supports PATH_CHECK. Commit 9bbb6cad0173 ("ima: rename
> ima_path_check to ima_file_check") renamed the function to
> ima_file_check(), but missed modifying the function name in the
> comment.
>
> Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").
>
> Signed-off-by: Jiele Zhao <[email protected]>

Thanks, Jiele.

Applied to
git://git.kernel.org/pub/scm/linux/kernel/git/zohar/linux-integrity.git
next-integrity

Mimi