2024-05-17 17:22:31

by Erick Archer

[permalink] [raw]
Subject: [PATCH v3 0/2] tty: rfcomm: refactor rfcomm_get_dev_list() function

This is an effort to get rid of all multiplications from allocation
functions in order to prevent integer overflows [1][2].

As the "dl" variable is a pointer to "struct rfcomm_dev_list_req" and
this structure ends in a flexible array:

struct rfcomm_dev_list_req {
[...]
struct rfcomm_dev_info dev_info[];
};

the preferred way in the kernel is to use the struct_size() helper to
do the arithmetic instead of the calculation "size + count * size" in
the kzalloc() and copy_to_user() functions.

At the same time, prepare for the coming implementation by GCC and Clang
of the __counted_by attribute. Flexible array members annotated with
__counted_by can have their accesses bounds-checked at run-time via
CONFIG_UBSAN_BOUNDS (for array indexing) and CONFIG_FORTIFY_SOURCE (for
strcpy/memcpy-family functions).

In this case, it is important to note that the logic needs a little
refactoring to ensure that the "dev_num" member is initialized before
the first access to the flex array. Specifically, add the assignment
before the list_for_each_entry() loop.

Also remove the "size" variable as it is no longer needed and refactor
the list_for_each_entry() loop to use di[n] instead of (di + n).

This way, the code is more readable, idiomatic and safer.

This code was detected with the help of Coccinelle, and audited and
modified manually.

Specifically, the first patch is related to the struct_size() helper
and the second patch refactors the list_for_each_entry() loop to use
array indexing instead of pointer arithmetic.

Regards,
Erick

Link: https://www.kernel.org/doc/html/latest/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
Link: https://github.com/KSPP/linux/issues/160 [2]
---
Changes in v3:
- Add the "Reviewed-by:" tags.
- Split the changes in two commits (Jiri Slaby, Luiz Augusto von Dentz).

Changes in v2:
- Add the __counted_by() attribute (Kees Cook).
- Refactor the list_for_each_entry() loop to use di[n] instead of
(di + n) (Kees Cook).

Previous versions:
v2 -> https://lore.kernel.org/linux-hardening/AS8PR02MB7237262C62B054FABD7229168BE12@AS8PR02MB7237.eurprd02.prod.outlook.com/
v1 -> https://lore.kernel.org/linux-hardening/AS8PR02MB723725E0069F7AE8F64E876E8B142@AS8PR02MB7237.eurprd02.prod.outlook.com/
---
Erick Archer (2):
tty: rfcomm: prefer struct_size over open coded arithmetic
tty: rfcomm: prefer array indexing over pointer arithmetic

include/net/bluetooth/rfcomm.h | 2 +-
net/bluetooth/rfcomm/tty.c | 23 ++++++++++-------------
2 files changed, 11 insertions(+), 14 deletions(-)

--
2.25.1



2024-05-20 19:51:05

by patchwork-bot+bluetooth

[permalink] [raw]
Subject: Re: [PATCH v3 0/2] tty: rfcomm: refactor rfcomm_get_dev_list() function

Hello:

This series was applied to bluetooth/bluetooth-next.git (master)
by Luiz Augusto von Dentz <[email protected]>:

On Fri, 17 May 2024 19:21:48 +0200 you wrote:
> This is an effort to get rid of all multiplications from allocation
> functions in order to prevent integer overflows [1][2].
>
> As the "dl" variable is a pointer to "struct rfcomm_dev_list_req" and
> this structure ends in a flexible array:
>
> struct rfcomm_dev_list_req {
> [...]
> struct rfcomm_dev_info dev_info[];
> };
>
> [...]

Here is the summary with links:
- [v3,1/2] tty: rfcomm: prefer struct_size over open coded arithmetic
https://git.kernel.org/bluetooth/bluetooth-next/c/b7a6ed60e5e6
- [v3,2/2] tty: rfcomm: prefer array indexing over pointer arithmetic
https://git.kernel.org/bluetooth/bluetooth-next/c/7b13a745870c

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html