[Please excuse me the openwrt syntax, I wrote this first on the openwrt forum]
When using multiple virtual interfaces like:
config wifi-device radio0
option type mac80211
option channel 6
...
config wifi-iface
option device radio0
option network wan
option mode sta
option ssid AP1
...
config wifi-iface
option device radio0
option network wlan
option mode AP2
If wan gets deassociated from AP1, it gets impossible to associate to AP2 network.
Looking with airodump-ng I see a few beacons sent on the right channel and that it's sending probes on the wrong channels. It seems that this channel hopping looking for AP1 is what breaks AP2.
It seems that devices in managed mode disregard the channel configuration. Is there any way to force it?
This has been tested on a TP-LINK MR3420 (AR9287)
Thanks!
--
Horacio J. Pe?a
[email protected]
[email protected]
Following on this, I've found that "It seems that this channel hopping looking
for AP1 is what breaks AP2." was wrong. I've tried a very dirty workaround,
making a fake regulatory domain that only allows channel 6. Then, there is no
channel hopping, but still the AP2 doesn't works. It sometimes sends out Probe
Responses but no beacons.
Some idea on where to look?
Thanks,
Horacio J. Pe?a
On Sat, Sep 17, 2011 at 05:55:07PM -0300, Horacio J. Pe?a wrote:
> [Please excuse me the openwrt syntax, I wrote this first on the openwrt forum]
>
> When using multiple virtual interfaces like:
>
>
> config wifi-device radio0
> option type mac80211
> option channel 6
> ...
>
> config wifi-iface
> option device radio0
> option network wan
> option mode sta
> option ssid AP1
> ...
> config wifi-iface
> option device radio0
> option network wlan
> option mode AP2
>
>
> If wan gets deassociated from AP1, it gets impossible to associate to AP2 network.
>
> Looking with airodump-ng I see a few beacons sent on the right channel and that it's sending probes on the wrong channels. It seems that this channel hopping looking for AP1 is what breaks AP2.
>
> It seems that devices in managed mode disregard the channel configuration. Is there any way to force it?
>
> This has been tested on a TP-LINK MR3420 (AR9287)
>
> Thanks!
> --
> Horacio J. Pe?a
> [email protected]
> [email protected]
> --
> To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
> the body of a message to [email protected]
> More majordomo info at http://vger.kernel.org/majordomo-info.html
--
Horacio J. Pe?a
[email protected]
[email protected]