Date |
List |
Subject |
2021-11-20 13:02:31
|
linux-kernel
|
[PATCH v2 18/20] linux/power_of_2.h: Add __IS_POWER_OF_2(n) and __IS_POWER_OF_2_OR_0(n) macros |
2021-11-20 13:02:25
|
linux-kernel
|
[PATCH v2 19/20] linux/build_bug.h, linux/power_of_2.h: Move [__]BUILD_BUG_ON_NOT_POWER_OF_2() to <linux/power_of_2.h> |
2021-11-20 13:02:17
|
linux-kernel
|
[PATCH v2 17/20] linux/array_size.h: Add __is_array(a) to help readability |
2021-11-20 13:02:06
|
linux-kernel
|
[PATCH v2 16/20] linux/compiler.h, linux/array_size.h: Move __must_be_array() into <linux/array_size.h> |
2021-11-20 13:01:57
|
linux-kernel
|
[PATCH v2 15/20] linux/compiler.h: Implement __must_be_array() in terms of __must_be() |
2021-11-20 13:01:55
|
linux-kernel
|
[PATCH v2 14/20] linux/compiler_types.h, linux/same_type.h: Split __same_type() to a separate header |
2021-11-20 13:01:53
|
linux-kernel
|
[PATCH v2 13/20] linux/build_bug.h, linux/must_be.h: Move BUILD_BUG_ON_ZERO to <linux/must_be.h> |
2021-11-20 13:01:50
|
linux-kernel
|
[PATCH v2 11/20] linux/container_of.h: Cosmetic |
2021-11-20 13:01:49
|
linux-kernel
|
[PATCH v2 12/20] linux/must_be.h: Add must_be() to improve readability of BUILD_BUG_ON_ZERO() |
2021-11-20 13:01:46
|
linux-kernel
|
[PATCH v2 13/20] Move BUILD_BUG_ON_ZERO to <linux/must_be.h> |
2021-11-20 13:01:43
|
linux-kernel
|
[PATCH v2 10/20] linux/container_of.h: Remove unnecessary cast |
2021-11-20 13:01:42
|
linux-kernel
|
[PATCH v2 09/20] Implement offsetof(), sizeof_member(), typeof_member(), and container_of() in terms of memberof() |
2021-11-20 13:01:39
|
linux-kernel
|
[PATCH v2 07/20] linux/memberof.h: Add memberof(T, m) macro |
2021-11-20 13:01:37
|
linux-kernel
|
[PATCH v2 08/20] Implement container_of_safe() in terms of container_of() |
2021-11-20 13:01:35
|
linux-kernel
|
[PATCH v2 04/20] linux/stddef.h, linux/NULL.h: Split NULL into a separate header |
2021-11-20 13:01:33
|
linux-kernel
|
[PATCH v2 05/20] linux/container_of.h, linux/typeof_member.h: Split typeof_member() into a separate header |
2021-11-20 13:01:29
|
linux-kernel
|
[PATCH v2 06/20] linux/kernel.h, linux/array_size.h: Split ARRAY_SIZE() into a separate header |
2021-11-20 13:01:28
|
linux-kernel
|
[PATCH v2 03/20] linux/stddef.h, linux/offsetofend.h: Split offsetofend() into a separate header |
2021-11-20 13:01:26
|
linux-kernel
|
[PATCH v2 01/20] linux/stddef.h, linux/offsetof.h: Split offsetof() into a separate header |
2021-11-20 13:01:26
|
linux-kernel
|
[PATCH v2 02/20] linux/stddef.h, linux/sizeof_field.h: Split sizeof_field() into a separate header |
2021-11-20 13:01:20
|
linux-kernel
|
[PATCH v2 00/20] Add memberof(), split headers, and simplify code |
2021-11-19 16:49:57
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 16:22:56
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 16:12:28
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 15:52:27
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 15:43:09
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 15:38:53
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 15:13:35
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 15:06:36
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 13:16:14
|
linux-kernel
|
Re: [PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-19 11:38:02
|
linux-kernel
|
[PATCH 17/17] include/: Include <linux/array_size.h> for ARRAY_SIZE() |
2021-11-19 11:37:59
|
linux-kernel
|
[PATCH 15/17] linux/offsetofend.h: Move offsetofend(T, m) to a separate header |
2021-11-19 11:37:59
|
linux-kernel
|
[PATCH 16/17] linux/array_size.h: Move ARRAY_SIZE(arr) to a separate header |
2021-11-19 11:37:55
|
linux-kernel
|
[PATCH 14/17] include/linux/: Include a smaller header if just for NULL |
2021-11-19 11:37:53
|
linux-kernel
|
[PATCH 13/17] linux/sizeof_field.h: Move sizeof_field(T, m) to a separate header |
2021-11-19 11:37:51
|
linux-kernel
|
[PATCH 12/17] linux/container_of.h: Remove unnecessary cast to (void *) |
2021-11-19 11:37:48
|
linux-kernel
|
[PATCH 11/17] linux/container_of.h: Cosmetic |
2021-11-19 11:37:45
|
linux-kernel
|
[PATCH 10/17] linux/container_of.h: Implement container_of_safe() in terms of container_of() |
2021-11-19 11:37:38
|
linux-kernel
|
[PATCH 08/17] linux/offsetof.h: Move offsetof(T, m) to a separate header |
2021-11-19 11:37:36
|
linux-kernel
|
[PATCH 09/17] linux/offsetof.h: Implement offsetof() in terms of memberof() |
2021-11-19 11:37:34
|
linux-kernel
|
[PATCH 07/17] linux/NULL.h: Move NULL to a separate header |
2021-11-19 11:37:31
|
linux-kernel
|
[PATCH 06/17] Simplify sizeof(typeof_member()) to sizeof_field() |
2021-11-19 11:37:28
|
linux-kernel
|
[PATCH 04/17] linux/memberof.h: Move memberof() to separate header |
2021-11-19 11:37:26
|
linux-kernel
|
[PATCH 03/17] Replace some uses of memberof() by its wrappers |
2021-11-19 11:37:23
|
linux-kernel
|
[PATCH 02/17] Use memberof(T, m) instead of explicit NULL dereference |
2021-11-19 11:37:21
|
linux-kernel
|
[PATCH 05/17] linux/typeof_member.h: Move typeof_member() to a separate header |
2021-11-19 11:37:17
|
linux-kernel
|
[PATCH 01/17] linux/container_of.h: Add memberof(T, m) |
2021-11-19 11:37:14
|
linux-kernel
|
[PATCH 00/17] Add memberof(), split some headers, and slightly simplify code |
2021-11-14 15:45:51
|
linux-kernel
|
Re: [PATCH v16 1/3] fs: Add trusted_for(2) syscall implementation and related sysctl |
2021-11-13 19:56:18
|
linux-kernel
|
Re: [PATCH v16 1/3] fs: Add trusted_for(2) syscall implementation and related sysctl |
2021-11-12 21:01:36
|
linux-kernel
|
Re: netdevice.7 SIOCGIFFLAGS/SIOCSIFFLAGS |