Switch to using the new API kobj_to_dev().
Signed-off-by: Tian Tao <[email protected]>
---
include/linux/i2c.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/i2c.h b/include/linux/i2c.h
index fc55ea4..5662265 100644
--- a/include/linux/i2c.h
+++ b/include/linux/i2c.h
@@ -344,7 +344,7 @@ const struct i2c_device_id *i2c_match_id(const struct i2c_device_id *id,
static inline struct i2c_client *kobj_to_i2c_client(struct kobject *kobj)
{
- struct device * const dev = container_of(kobj, struct device, kobj);
+ struct device * const dev = kobj_to_dev(kobj);
return to_i2c_client(dev);
}
--
2.7.4
> static inline struct i2c_client *kobj_to_i2c_client(struct kobject *kobj)
> {
> - struct device * const dev = container_of(kobj, struct device, kobj);
> + struct device * const dev = kobj_to_dev(kobj);
> return to_i2c_client(dev);
Can't we make this a oneliner then merging the last two lines?
在 2020/9/19 5:09, [email protected] 写道:
>
>> static inline struct i2c_client *kobj_to_i2c_client(struct kobject *kobj)
>> {
>> - struct device * const dev = container_of(kobj, struct device, kobj);
>> + struct device * const dev = kobj_to_dev(kobj);
>> return to_i2c_client(dev);
>
> Can't we make this a oneliner then merging the last two lines?
>
I think two lines have better readability, and if you prefer one line, I
can send v2 to fix that!
On Sat, Sep 19, 2020 at 09:01:12AM +0800, tiantao (H) wrote:
>
>
> 在 2020/9/19 5:09, [email protected] 写道:
> >
> > > static inline struct i2c_client *kobj_to_i2c_client(struct kobject *kobj)
> > > {
> > > - struct device * const dev = container_of(kobj, struct device, kobj);
> > > + struct device * const dev = kobj_to_dev(kobj);
> > > return to_i2c_client(dev);
> >
> > Can't we make this a oneliner then merging the last two lines?
> >
> I think two lines have better readability, and if you prefer one line, I can
> send v2 to fix that!
I just found d75d53cd571c ("i2c: Fix sparse warning in i2c.h"), so we
should leave the two lines. Thanks!
On Tue, Sep 15, 2020 at 09:38:18AM +0800, Tian Tao wrote:
> Switch to using the new API kobj_to_dev().
>
> Signed-off-by: Tian Tao <[email protected]>
Applied to for-next, thanks!