2013-04-19 13:39:00

by Michal Bachraty

[permalink] [raw]
Subject: [PATCH 1/2] ALSA: ASoc: spdif_transciever: Add DT support

Add devicetree support for this dummy audio soc driver.

Signed-off-by: Michal Bachraty <[email protected]>
---
sound/soc/codecs/spdif_transciever.c | 10 ++++++++++
1 file changed, 10 insertions(+)

diff --git a/sound/soc/codecs/spdif_transciever.c b/sound/soc/codecs/spdif_transciever.c
index 112a49d..4c8c295 100644
--- a/sound/soc/codecs/spdif_transciever.c
+++ b/sound/soc/codecs/spdif_transciever.c
@@ -20,6 +20,7 @@
#include <sound/soc.h>
#include <sound/pcm.h>
#include <sound/initval.h>
+#include <linux/of.h>

#define DRV_NAME "spdif-dit"

@@ -52,12 +53,21 @@ static int spdif_dit_remove(struct platform_device *pdev)
return 0;
}

+#ifdef CONFIG_OF
+static const struct of_device_id spdif_dit_dt_ids[] = {
+ { .compatible = DRV_NAME, },
+ { }
+};
+MODULE_DEVICE_TABLE(of, spdif_dits_dt_ids);
+#endif
+
static struct platform_driver spdif_dit_driver = {
.probe = spdif_dit_probe,
.remove = spdif_dit_remove,
.driver = {
.name = DRV_NAME,
.owner = THIS_MODULE,
+ .of_match_table = of_match_ptr(spdif_dit_dt_ids),
},
};

--
1.7.9.5


2013-04-19 17:36:07

by Daniel Mack

[permalink] [raw]
Subject: Re: [PATCH 1/2] ALSA: ASoc: spdif_transciever: Add DT support

Hi Michal,

On 19.04.2013 15:38, Michal Bachraty wrote:
> Add devicetree support for this dummy audio soc driver.

I think Mark wants to see only "ASoC:" in the patch subjects now.

>
> Signed-off-by: Michal Bachraty <[email protected]>
> ---
> sound/soc/codecs/spdif_transciever.c | 10 ++++++++++
> 1 file changed, 10 insertions(+)
>
> diff --git a/sound/soc/codecs/spdif_transciever.c b/sound/soc/codecs/spdif_transciever.c
> index 112a49d..4c8c295 100644
> --- a/sound/soc/codecs/spdif_transciever.c
> +++ b/sound/soc/codecs/spdif_transciever.c
> @@ -20,6 +20,7 @@
> #include <sound/soc.h>
> #include <sound/pcm.h>
> #include <sound/initval.h>
> +#include <linux/of.h>
>
> #define DRV_NAME "spdif-dit"
>
> @@ -52,12 +53,21 @@ static int spdif_dit_remove(struct platform_device *pdev)
> return 0;
> }
>
> +#ifdef CONFIG_OF
> +static const struct of_device_id spdif_dit_dt_ids[] = {
> + { .compatible = DRV_NAME, },

I think this needs a "linux," prefix. Just put the whole string here.

Same goes for the patch against the spdif_receiver driver.


Thanks,
Daniel


> + { }
> +};
> +MODULE_DEVICE_TABLE(of, spdif_dits_dt_ids);
> +#endif
> +
> static struct platform_driver spdif_dit_driver = {
> .probe = spdif_dit_probe,
> .remove = spdif_dit_remove,
> .driver = {
> .name = DRV_NAME,
> .owner = THIS_MODULE,
> + .of_match_table = of_match_ptr(spdif_dit_dt_ids),
> },
> };
>
>

2013-04-23 13:49:23

by Mark Brown

[permalink] [raw]
Subject: Re: [PATCH 1/2] ALSA: ASoc: spdif_transciever: Add DT support

On Fri, Apr 19, 2013 at 03:38:45PM +0200, Michal Bachraty wrote:
> Add devicetree support for this dummy audio soc driver.
>
> Signed-off-by: Michal Bachraty <[email protected]>
> ---
> sound/soc/codecs/spdif_transciever.c | 10 ++++++++++
> 1 file changed, 10 insertions(+)

New device tree bindings need a binding document.


Attachments:
(No filename) (348.00 B)
signature.asc (836.00 B)
Digital signature
Download all attachments

2013-04-23 14:02:13

by Sebastian Hesselbarth

[permalink] [raw]
Subject: Re: [PATCH 1/2] ALSA: ASoc: spdif_transciever: Add DT support

On Fri, Apr 19, 2013 at 7:36 PM, Daniel Mack <[email protected]> wrote:
> Hi Michal,
>
> On 19.04.2013 15:38, Michal Bachraty wrote:
>> Add devicetree support for this dummy audio soc driver.
>
> I think Mark wants to see only "ASoC:" in the patch subjects now.
>
>>
>> Signed-off-by: Michal Bachraty <[email protected]>
>> ---
>> sound/soc/codecs/spdif_transciever.c | 10 ++++++++++
>> 1 file changed, 10 insertions(+)
>>
>> diff --git a/sound/soc/codecs/spdif_transciever.c b/sound/soc/codecs/spdif_transciever.c
>> index 112a49d..4c8c295 100644
>> --- a/sound/soc/codecs/spdif_transciever.c
>> +++ b/sound/soc/codecs/spdif_transciever.c
>> @@ -20,6 +20,7 @@
>> #include <sound/soc.h>
>> #include <sound/pcm.h>
>> #include <sound/initval.h>
>> +#include <linux/of.h>
>>
>> #define DRV_NAME "spdif-dit"
>>
>> @@ -52,12 +53,21 @@ static int spdif_dit_remove(struct platform_device *pdev)
>> return 0;
>> }
>>
>> +#ifdef CONFIG_OF
>> +static const struct of_device_id spdif_dit_dt_ids[] = {
>> + { .compatible = DRV_NAME, },
>
> I think this needs a "linux," prefix. Just put the whole string here.

Michal,

I suggest to also rename spdif_transceiver to spdif_transmitter, as
"transceiver"
usually do both "transmit" and "receive". I don't know who made up the current
name, but the driver is definitely a transmitter.

Sebastian