If devm_add_action() fails we are explicitly calling dma_unmap_single()
and kfree(). Lets use the helper devm_add_action_or_reset() and return
directly in case of error, as we know that the cleanup function has been
already called by the helper if there was any error.
Signed-off-by: Sudip Mukherjee <[email protected]>
---
drivers/char/xillybus/xillybus_of.c | 7 ++-----
drivers/char/xillybus/xillybus_pcie.c | 7 ++-----
2 files changed, 4 insertions(+), 10 deletions(-)
diff --git a/drivers/char/xillybus/xillybus_of.c b/drivers/char/xillybus/xillybus_of.c
index 7818650..17f45b6 100644
--- a/drivers/char/xillybus/xillybus_of.c
+++ b/drivers/char/xillybus/xillybus_of.c
@@ -101,13 +101,10 @@ static int xilly_map_single_of(struct xilly_endpoint *ep,
*ret_dma_handle = addr;
- rc = devm_add_action(ep->dev, xilly_of_unmap, this);
+ rc = devm_add_action_or_reset(ep->dev, xilly_of_unmap, this);
- if (rc) {
- dma_unmap_single(ep->dev, addr, size, direction);
- kfree(this);
+ if (rc)
return rc;
- }
return 0;
}
diff --git a/drivers/char/xillybus/xillybus_pcie.c b/drivers/char/xillybus/xillybus_pcie.c
index 9418300..99c688f 100644
--- a/drivers/char/xillybus/xillybus_pcie.c
+++ b/drivers/char/xillybus/xillybus_pcie.c
@@ -120,12 +120,9 @@ static int xilly_map_single_pci(struct xilly_endpoint *ep,
*ret_dma_handle = addr;
- rc = devm_add_action(ep->dev, xilly_pci_unmap, this);
- if (rc) {
- pci_unmap_single(ep->pdev, addr, size, pci_direction);
- kfree(this);
+ rc = devm_add_action_or_reset(ep->dev, xilly_pci_unmap, this);
+ if (rc)
return rc;
- }
return 0;
}
--
1.9.1
Thanks,
I like the direction, however both xilly_map_single_* functions turn out
ending with
if (rc)
return rc;
return 0;
Which is equivalent to just "return rc". Or maybe return the value of
the devm_add_action_or_reset() call directly, and remove the "rc"
variable? I don't know which one is better coding style.
Could you please take care of that and resubmit? Just want to save
ourselves another patch that fixes this.
Regards,
Eli
On 25/04/16 23:51, Sudip Mukherjee wrote:
> If devm_add_action() fails we are explicitly calling dma_unmap_single()
> and kfree(). Lets use the helper devm_add_action_or_reset() and return
> directly in case of error, as we know that the cleanup function has been
> already called by the helper if there was any error.
>
> Signed-off-by: Sudip Mukherjee<[email protected]>
> ---
> drivers/char/xillybus/xillybus_of.c | 7 ++-----
> drivers/char/xillybus/xillybus_pcie.c | 7 ++-----
> 2 files changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/char/xillybus/xillybus_of.c b/drivers/char/xillybus/xillybus_of.c
> index 7818650..17f45b6 100644
> --- a/drivers/char/xillybus/xillybus_of.c
> +++ b/drivers/char/xillybus/xillybus_of.c
> @@ -101,13 +101,10 @@ static int xilly_map_single_of(struct xilly_endpoint *ep,
>
> *ret_dma_handle = addr;
>
> - rc = devm_add_action(ep->dev, xilly_of_unmap, this);
> + rc = devm_add_action_or_reset(ep->dev, xilly_of_unmap, this);
>
> - if (rc) {
> - dma_unmap_single(ep->dev, addr, size, direction);
> - kfree(this);
> + if (rc)
> return rc;
> - }
>
> return 0;
> }
> diff --git a/drivers/char/xillybus/xillybus_pcie.c b/drivers/char/xillybus/xillybus_pcie.c
> index 9418300..99c688f 100644
> --- a/drivers/char/xillybus/xillybus_pcie.c
> +++ b/drivers/char/xillybus/xillybus_pcie.c
> @@ -120,12 +120,9 @@ static int xilly_map_single_pci(struct xilly_endpoint *ep,
>
> *ret_dma_handle = addr;
>
> - rc = devm_add_action(ep->dev, xilly_pci_unmap, this);
> - if (rc) {
> - pci_unmap_single(ep->pdev, addr, size, pci_direction);
> - kfree(this);
> + rc = devm_add_action_or_reset(ep->dev, xilly_pci_unmap, this);
> + if (rc)
> return rc;
> - }
>
> return 0;
> }
>
On Tue, Apr 26, 2016 at 01:23:08PM +0300, Eli Billauer wrote:
> Thanks,
>
> I like the direction, however both xilly_map_single_* functions turn
> out ending with
>
> if (rc)
> return rc;
>
> return 0;
>
> Which is equivalent to just "return rc". Or maybe return the value
> of the devm_add_action_or_reset() call directly, and remove the "rc"
> variable? I don't know which one is better coding style.
ofcourse, it was very silly of me not to notice that.
v2 sent for your consideration.
regards
sudip