S?bastien Dugu? wrote:
>
> +struct task_struct *good_sigevent(sigevent_t *event)
> +{
> + struct task_struct *task = current->group_leader;
> +
> + if ((event->sigev_notify & SIGEV_THREAD_ID) == SIGEV_THREAD_ID) {
> + task = find_task_by_pid(event->sigev_notify_thread_id);
> +
> + if (!task || task->tgid != current->tgid)
> + return NULL;
> + } else if (event->sigev_notify == SIGEV_SIGNAL) {
No, no, we can't use "else" here,
> + if (event->sigev_signo <= 0 || event->sigev_signo > SIGRTMAX)
because we skip the check above in SIGEV_THREAD_ID case.
This way any user can crash the kernel with a minimal effort.
Oleg.
On Thu, 25 Jan 2007 18:43:24 +0300 Oleg Nesterov <[email protected]> wrote:
> SИbastien DuguИ wrote:
> >
> > +struct task_struct *good_sigevent(sigevent_t *event)
> > +{
> > + struct task_struct *task = current->group_leader;
> > +
> > + if ((event->sigev_notify & SIGEV_THREAD_ID) == SIGEV_THREAD_ID) {
> > + task = find_task_by_pid(event->sigev_notify_thread_id);
> > +
> > + if (!task || task->tgid != current->tgid)
> > + return NULL;
> > + } else if (event->sigev_notify == SIGEV_SIGNAL) {
>
> No, no, we can't use "else" here,
>
> > + if (event->sigev_signo <= 0 || event->sigev_signo > SIGRTMAX)
>
> because we skip the check above in SIGEV_THREAD_ID case.
Right, will fix this.
>
> This way any user can crash the kernel with a minimal effort.
Well I tried, no crash, just the signal failing to be delivered.
Thanks,
Sébastien.
On 01/26, S?bastien Dugu? wrote:
>
> On Thu, 25 Jan 2007 18:43:24 +0300 Oleg Nesterov <[email protected]> wrote:
>
> > S?bastien Dugu? wrote:
> > >
> > > +struct task_struct *good_sigevent(sigevent_t *event)
> > > +{
> > > + struct task_struct *task = current->group_leader;
> > > +
> > > + if ((event->sigev_notify & SIGEV_THREAD_ID) == SIGEV_THREAD_ID) {
> > > + task = find_task_by_pid(event->sigev_notify_thread_id);
> > > +
> > > + if (!task || task->tgid != current->tgid)
> > > + return NULL;
> > > + } else if (event->sigev_notify == SIGEV_SIGNAL) {
> >
> > No, no, we can't use "else" here,
> >
> > > + if (event->sigev_signo <= 0 || event->sigev_signo > SIGRTMAX)
> >
> > because we skip the check above in SIGEV_THREAD_ID case.
>
> Right, will fix this.
>
> >
> > This way any user can crash the kernel with a minimal effort.
>
> Well I tried, no crash, just the signal failing to be delivered.
sigaddset:
set->sig[sig / _NSIG_BPW] |= 1UL << (sig % _NSIG_BPW);
This writes to ->sig[event->sigev_signo / _NSIG_BPW] location, so we can
corrupt the memory if ->sigev_signo > _NSIG.
Btw, since you are exporting this function, may I suggest to rename it?
No, I can't suggest a better name :) But "good_sigevent" is a bit confusing
imho.
Oleg.
On Fri, 26 Jan 2007 13:08:01 +0300 Oleg Nesterov <[email protected]> wrote:
> On 01/26, S?bastien Dugu? wrote:
> >
> > On Thu, 25 Jan 2007 18:43:24 +0300 Oleg Nesterov <[email protected]> wrote:
> >
> > > SИbastien DuguИ wrote:
> > > >
> > > > +struct task_struct *good_sigevent(sigevent_t *event)
> > > > +{
> > > > + struct task_struct *task = current->group_leader;
> > > > +
> > > > + if ((event->sigev_notify & SIGEV_THREAD_ID) == SIGEV_THREAD_ID) {
> > > > + task = find_task_by_pid(event->sigev_notify_thread_id);
> > > > +
> > > > + if (!task || task->tgid != current->tgid)
> > > > + return NULL;
> > > > + } else if (event->sigev_notify == SIGEV_SIGNAL) {
> > >
> > > No, no, we can't use "else" here,
> > >
> > > > + if (event->sigev_signo <= 0 || event->sigev_signo > SIGRTMAX)
> > >
> > > because we skip the check above in SIGEV_THREAD_ID case.
> >
> > Right, will fix this.
> >
> > >
> > > This way any user can crash the kernel with a minimal effort.
> >
> > Well I tried, no crash, just the signal failing to be delivered.
>
> sigaddset:
>
> set->sig[sig / _NSIG_BPW] |= 1UL << (sig % _NSIG_BPW);
>
> This writes to ->sig[event->sigev_signo / _NSIG_BPW] location, so we can
> corrupt the memory if ->sigev_signo > _NSIG.
Gawd, right.
>
> Btw, since you are exporting this function, may I suggest to rename it?
> No, I can't suggest a better name :) But "good_sigevent" is a bit confusing
> imho.
I agree, there was a discussion concerning this a while back but nothing came
out of it and I left it as is.
I will try to find something more suggestive.
Thanks,
Sébastien.