2015-12-03 14:17:36

by Geliang Tang

[permalink] [raw]
Subject: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

To make the intention clearer, use list_{first,next}_entry instead
of list_entry.

Signed-off-by: Geliang Tang <[email protected]>
---
mm/memcontrol.c | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)

diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index 79a29d5..a6301ea 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
unsigned long nr_file = 0;
unsigned long nr_huge = 0;
unsigned long pgpgout = 0;
- struct list_head *next;
struct page *page;

- next = page_list->next;
+ page = list_first_entry(page_list, struct page, lru);
do {
unsigned int nr_pages = 1;

- page = list_entry(next, struct page, lru);
- next = page->lru.next;
-
VM_BUG_ON_PAGE(PageLRU(page), page);
VM_BUG_ON_PAGE(page_count(page), page);

@@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
page->mem_cgroup = NULL;

pgpgout++;
- } while (next != page_list);
+ } while (!list_is_last(&page->lru, page_list) &&
+ (page = list_next_entry(page, lru)));

if (memcg)
uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
--
2.5.0


2015-12-03 16:27:23

by Michal Hocko

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> To make the intention clearer, use list_{first,next}_entry instead
> of list_entry.

Does this really help readability? This function simply uncharges the
given list of pages. Why cannot we simply use list_for_each_entry
instead...

> Signed-off-by: Geliang Tang <[email protected]>
> ---
> mm/memcontrol.c | 9 +++------
> 1 file changed, 3 insertions(+), 6 deletions(-)
>
> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> index 79a29d5..a6301ea 100644
> --- a/mm/memcontrol.c
> +++ b/mm/memcontrol.c
> @@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
> unsigned long nr_file = 0;
> unsigned long nr_huge = 0;
> unsigned long pgpgout = 0;
> - struct list_head *next;
> struct page *page;
>
> - next = page_list->next;
> + page = list_first_entry(page_list, struct page, lru);
> do {
> unsigned int nr_pages = 1;
>
> - page = list_entry(next, struct page, lru);
> - next = page->lru.next;
> -
> VM_BUG_ON_PAGE(PageLRU(page), page);
> VM_BUG_ON_PAGE(page_count(page), page);
>
> @@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
> page->mem_cgroup = NULL;
>
> pgpgout++;
> - } while (next != page_list);
> + } while (!list_is_last(&page->lru, page_list) &&
> + (page = list_next_entry(page, lru)));
>
> if (memcg)
> uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
> --
> 2.5.0
>

--
Michal Hocko
SUSE Labs

2015-12-03 19:28:04

by Johannes Weiner

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > To make the intention clearer, use list_{first,next}_entry instead
> > of list_entry.
>
> Does this really help readability? This function simply uncharges the
> given list of pages. Why cannot we simply use list_for_each_entry
> instead...

You asked the same thing when reviewing the patch for the first
time. :-) I think it's time to add a comment.

>From e8ba3f31bb43ed4091b997b6ee8857dc8bbcd349 Mon Sep 17 00:00:00 2001
From: Johannes Weiner <[email protected]>
Date: Thu, 3 Dec 2015 14:21:45 -0500
Subject: [PATCH] mm: memcontrol: clarify the uncharge_list() loop

uncharge_list() does an unusual list walk because the function can
take regular lists with dedicated list_heads as well as singleton
lists where a single page is passed via its page->lru list node.

This can sometimes lead to confusion, as well as suggestions to
replace the loop with a list_for_each_entry(), which wouldn't work.

Signed-off-by: Johannes Weiner <[email protected]>
---
mm/memcontrol.c | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/mm/memcontrol.c b/mm/memcontrol.c
index 9acfb16..f7ee1c0 100644
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -5422,6 +5422,10 @@ static void uncharge_list(struct list_head *page_list)
struct list_head *next;
struct page *page;

+ /*
+ * Note that the list can be a single page->lru; hence the
+ * do-while loop instead of a simple list_for_each_entry().
+ */
next = page_list->next;
do {
unsigned int nr_pages = 1;
--
2.6.3

2015-12-04 08:46:17

by Michal Hocko

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Thu 03-12-15 14:27:50, Johannes Weiner wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> You asked the same thing when reviewing the patch for the first
> time. :-) I think it's time to add a comment.

Ohh, I completely forgot about mem_cgroup_uncharge doing
uncharge_list(&page->lru)

> >From e8ba3f31bb43ed4091b997b6ee8857dc8bbcd349 Mon Sep 17 00:00:00 2001
> From: Johannes Weiner <[email protected]>
> Date: Thu, 3 Dec 2015 14:21:45 -0500
> Subject: [PATCH] mm: memcontrol: clarify the uncharge_list() loop
>
> uncharge_list() does an unusual list walk because the function can
> take regular lists with dedicated list_heads as well as singleton
> lists where a single page is passed via its page->lru list node.
>
> This can sometimes lead to confusion, as well as suggestions to
> replace the loop with a list_for_each_entry(), which wouldn't work.

Yes, this is helpful.

> Signed-off-by: Johannes Weiner <[email protected]>

Acked-by: Michal Hocko <[email protected]>

> ---
> mm/memcontrol.c | 4 ++++
> 1 file changed, 4 insertions(+)
>
> diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> index 9acfb16..f7ee1c0 100644
> --- a/mm/memcontrol.c
> +++ b/mm/memcontrol.c
> @@ -5422,6 +5422,10 @@ static void uncharge_list(struct list_head *page_list)
> struct list_head *next;
> struct page *page;
>
> + /*
> + * Note that the list can be a single page->lru; hence the
> + * do-while loop instead of a simple list_for_each_entry().
> + */
> next = page_list->next;
> do {
> unsigned int nr_pages = 1;
> --
> 2.6.3

--
Michal Hocko
SUSE Labs

2015-12-05 02:56:38

by Geliang Tang

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > To make the intention clearer, use list_{first,next}_entry instead
> > of list_entry.
>
> Does this really help readability? This function simply uncharges the
> given list of pages. Why cannot we simply use list_for_each_entry
> instead...

I have tested it, list_for_each_entry can't work. Dose it mean that my
patch is OK? Or please give me some other advices.

Thanks.

- Geliang

> > Signed-off-by: Geliang Tang <[email protected]>
> > ---
> > mm/memcontrol.c | 9 +++------
> > 1 file changed, 3 insertions(+), 6 deletions(-)
> >
> > diff --git a/mm/memcontrol.c b/mm/memcontrol.c
> > index 79a29d5..a6301ea 100644
> > --- a/mm/memcontrol.c
> > +++ b/mm/memcontrol.c
> > @@ -5395,16 +5395,12 @@ static void uncharge_list(struct list_head *page_list)
> > unsigned long nr_file = 0;
> > unsigned long nr_huge = 0;
> > unsigned long pgpgout = 0;
> > - struct list_head *next;
> > struct page *page;
> >
> > - next = page_list->next;
> > + page = list_first_entry(page_list, struct page, lru);
> > do {
> > unsigned int nr_pages = 1;
> >
> > - page = list_entry(next, struct page, lru);
> > - next = page->lru.next;
> > -
> > VM_BUG_ON_PAGE(PageLRU(page), page);
> > VM_BUG_ON_PAGE(page_count(page), page);
> >
> > @@ -5440,7 +5436,8 @@ static void uncharge_list(struct list_head *page_list)
> > page->mem_cgroup = NULL;
> >
> > pgpgout++;
> > - } while (next != page_list);
> > + } while (!list_is_last(&page->lru, page_list) &&
> > + (page = list_next_entry(page, lru)));
> >
> > if (memcg)
> > uncharge_batch(memcg, pgpgout, nr_anon, nr_file,
> > --
> > 2.5.0
> >

2015-12-05 16:23:13

by Johannes Weiner

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Sat, Dec 05, 2015 at 10:55:42AM +0800, Geliang Tang wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> I have tested it, list_for_each_entry can't work. Dose it mean that my
> patch is OK? Or please give me some other advices.

Your patch is okay. Please feel free to add my

Acked-by: Johannes Weiner <[email protected]>

2015-12-07 16:21:10

by Michal Hocko

[permalink] [raw]
Subject: Re: [PATCH] mm/memcontrol.c: use list_{first,next}_entry

On Sat 05-12-15 10:55:42, Geliang Tang wrote:
> On Thu, Dec 03, 2015 at 05:27:18PM +0100, Michal Hocko wrote:
> > On Thu 03-12-15 22:16:55, Geliang Tang wrote:
> > > To make the intention clearer, use list_{first,next}_entry instead
> > > of list_entry.
> >
> > Does this really help readability? This function simply uncharges the
> > given list of pages. Why cannot we simply use list_for_each_entry
> > instead...
>
> I have tested it, list_for_each_entry can't work. Dose it mean that my
> patch is OK? Or please give me some other advices.

I dunno. Your change is technically correct of course. I find the exit
condition easier to read without your patch though.

--
Michal Hocko
SUSE Labs