2018-05-24 22:41:28

by Yafang Shao

[permalink] [raw]
Subject: [PATCH net-next] tcp: use data length instead of skb->len in tcp_probe

skb->len is meaningless to user.
data length could be more helpful, with which we can easily filter out
the packet without payload.

Signed-off-by: Yafang Shao <[email protected]>
---
include/trace/events/tcp.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/include/trace/events/tcp.h b/include/trace/events/tcp.h
index c1a5284..259b991 100644
--- a/include/trace/events/tcp.h
+++ b/include/trace/events/tcp.h
@@ -261,7 +261,7 @@
__entry->dport = ntohs(inet->inet_dport);
__entry->mark = skb->mark;

- __entry->length = skb->len;
+ __entry->length = skb->len - tcp_hdrlen(skb);
__entry->snd_nxt = tp->snd_nxt;
__entry->snd_una = tp->snd_una;
__entry->snd_cwnd = tp->snd_cwnd;
@@ -272,7 +272,7 @@
__entry->sock_cookie = sock_gen_cookie(sk);
),

- TP_printk("src=%pISpc dest=%pISpc mark=%#x length=%d snd_nxt=%#x snd_una=%#x snd_cwnd=%u ssthresh=%u snd_wnd=%u srtt=%u rcv_wnd=%u sock_cookie=%llx",
+ TP_printk("src=%pISpc dest=%pISpc mark=%#x data_len=%d snd_nxt=%#x snd_una=%#x snd_cwnd=%u ssthresh=%u snd_wnd=%u srtt=%u rcv_wnd=%u sock_cookie=%llx",
__entry->saddr, __entry->daddr, __entry->mark,
__entry->length, __entry->snd_nxt, __entry->snd_una,
__entry->snd_cwnd, __entry->ssthresh, __entry->snd_wnd,
--
1.8.3.1



2018-05-25 02:36:27

by Song Liu

[permalink] [raw]
Subject: Re: [PATCH net-next] tcp: use data length instead of skb->len in tcp_probe



> On May 24, 2018, at 5:48 AM, Yafang Shao <[email protected]> wrote:
>
> skb->len is meaningless to user.
> data length could be more helpful, with which we can easily filter out
> the packet without payload.
>
> Signed-off-by: Yafang Shao <[email protected]>
> ---
> include/trace/events/tcp.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/include/trace/events/tcp.h b/include/trace/events/tcp.h
> index c1a5284..259b991 100644
> --- a/include/trace/events/tcp.h
> +++ b/include/trace/events/tcp.h
> @@ -261,7 +261,7 @@
> __entry->dport = ntohs(inet->inet_dport);
> __entry->mark = skb->mark;
>
> - __entry->length = skb->len;
> + __entry->length = skb->len - tcp_hdrlen(skb);

We should also rename __entry->length to __entry->data_len, so that whoever
using this field will notice the change.

Thanks,
Song


> __entry->snd_nxt = tp->snd_nxt;
> __entry->snd_una = tp->snd_una;
> __entry->snd_cwnd = tp->snd_cwnd;
> @@ -272,7 +272,7 @@
> __entry->sock_cookie = sock_gen_cookie(sk);
> ),
>
> - TP_printk("src=%pISpc dest=%pISpc mark=%#x length=%d snd_nxt=%#x snd_una=%#x snd_cwnd=%u ssthresh=%u snd_wnd=%u srtt=%u rcv_wnd=%u sock_cookie=%llx",
> + TP_printk("src=%pISpc dest=%pISpc mark=%#x data_len=%d snd_nxt=%#x snd_una=%#x snd_cwnd=%u ssthresh=%u snd_wnd=%u srtt=%u rcv_wnd=%u sock_cookie=%llx",
> __entry->saddr, __entry->daddr, __entry->mark,
> __entry->length, __entry->snd_nxt, __entry->snd_una,
> __entry->snd_cwnd, __entry->ssthresh, __entry->snd_wnd,
> --
> 1.8.3.1
>


2018-05-25 20:28:08

by David Miller

[permalink] [raw]
Subject: Re: [PATCH net-next] tcp: use data length instead of skb->len in tcp_probe

From: Song Liu <[email protected]>
Date: Thu, 24 May 2018 17:44:46 +0000

> We should also rename __entry->length to __entry->data_len, so that whoever
> using this field will notice the change.

Agreed.