2021-05-06 08:56:49

by Xiaofei Tan

[permalink] [raw]
Subject: [PATCH] RDMA/ucma: Cleanup to reduce duplicate code

The lable "err1" does the same thing as the branch of copy_to_user()
failed in the function ucma_create_id(). Just jump to the label directly
to reduce duplicate code.

Signed-off-by: Xiaofei Tan <[email protected]>
---
drivers/infiniband/core/ucma.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/infiniband/core/ucma.c b/drivers/infiniband/core/ucma.c
index 15d57ba..1f198c1 100644
--- a/drivers/infiniband/core/ucma.c
+++ b/drivers/infiniband/core/ucma.c
@@ -468,8 +468,8 @@ static ssize_t ucma_create_id(struct ucma_file *file, const char __user *inbuf,
resp.id = ctx->id;
if (copy_to_user(u64_to_user_ptr(cmd.response),
&resp, sizeof(resp))) {
- ucma_destroy_private_ctx(ctx);
- return -EFAULT;
+ ret = -EFAULT;
+ goto err1;
}

mutex_lock(&file->mut);
--
2.8.1


2021-05-06 10:07:10

by Leon Romanovsky

[permalink] [raw]
Subject: Re: [PATCH] RDMA/ucma: Cleanup to reduce duplicate code

On Thu, May 06, 2021 at 04:51:46PM +0800, Xiaofei Tan wrote:
> The lable "err1" does the same thing as the branch of copy_to_user()
> failed in the function ucma_create_id(). Just jump to the label directly
> to reduce duplicate code.
>
> Signed-off-by: Xiaofei Tan <[email protected]>
> ---
> drivers/infiniband/core/ucma.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>

Thanks,
Reviewed-by: Leon Romanovsky <[email protected]>

2021-05-11 19:38:57

by Jason Gunthorpe

[permalink] [raw]
Subject: Re: [PATCH] RDMA/ucma: Cleanup to reduce duplicate code

On Thu, May 06, 2021 at 04:51:46PM +0800, Xiaofei Tan wrote:
> The lable "err1" does the same thing as the branch of copy_to_user()
> failed in the function ucma_create_id(). Just jump to the label directly
> to reduce duplicate code.
>
> Signed-off-by: Xiaofei Tan <[email protected]>
> Reviewed-by: Leon Romanovsky <[email protected]>
> ---
> drivers/infiniband/core/ucma.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)

Applied to for-next, thanks

Jason