Subject: [PATCH 1/2] dt-bindings: usb: mt6360-tcpc: Rename IRQ to PD-IRQB

Since there is no user yet, rename the only interrupt of this device
to "PD-IRQB", avoiding underscores.

Signed-off-by: AngeloGioacchino Del Regno <[email protected]>
---
.../devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
index 053264e60583..0bea23ce2f09 100644
--- a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
+++ b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
@@ -24,7 +24,7 @@ properties:

interrupt-names:
items:
- - const: PD_IRQB
+ - const: PD-IRQB

connector:
type: object
@@ -58,7 +58,7 @@ examples:
tcpc {
compatible = "mediatek,mt6360-tcpc";
interrupts-extended = <&gpio26 3 IRQ_TYPE_LEVEL_LOW>;
- interrupt-names = "PD_IRQB";
+ interrupt-names = "PD-IRQB";

connector {
compatible = "usb-c-connector";
--
2.43.0



2024-01-12 11:16:32

by Rob Herring (Arm)

[permalink] [raw]
Subject: Re: [PATCH 1/2] dt-bindings: usb: mt6360-tcpc: Rename IRQ to PD-IRQB


On Fri, 12 Jan 2024 10:45:37 +0100, AngeloGioacchino Del Regno wrote:
> Since there is no user yet, rename the only interrupt of this device
> to "PD-IRQB", avoiding underscores.
>
> Signed-off-by: AngeloGioacchino Del Regno <[email protected]>
> ---
> .../devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>

My bot found errors running 'make DT_CHECKER_FLAGS=-m dt_binding_check'
on your patch (DT_CHECKER_FLAGS is new in v5.13):

yamllint warnings/errors:

dtschema/dtc warnings/errors:
/builds/robherring/dt-review-ci/linux/Documentation/devicetree/bindings/mfd/mediatek,mt6360.example.dtb: pmic@34: tcpc:interrupt-names:0: 'PD-IRQB' was expected
from schema $id: http://devicetree.org/schemas/mfd/mediatek,mt6360.yaml#
/builds/robherring/dt-review-ci/linux/Documentation/devicetree/bindings/mfd/mediatek,mt6360.example.dtb: tcpc: interrupt-names:0: 'PD-IRQB' was expected
from schema $id: http://devicetree.org/schemas/usb/mediatek,mt6360-tcpc.yaml#

doc reference errors (make refcheckdocs):

See https://patchwork.ozlabs.org/project/devicetree-bindings/patch/[email protected]

The base for the series is generally the latest rc1. A different dependency
should be noted in *this* patch.

If you already ran 'make dt_binding_check' and didn't see the above
error(s), then make sure 'yamllint' is installed and dt-schema is up to
date:

pip3 install dtschema --upgrade

Please check and re-submit after running the above command yourself. Note
that DT_SCHEMA_FILES can be set to your schema file to speed up checking
your schema. However, it must be unset to test all examples with your schema.


2024-01-12 14:20:36

by Rob Herring (Arm)

[permalink] [raw]
Subject: Re: [PATCH 1/2] dt-bindings: usb: mt6360-tcpc: Rename IRQ to PD-IRQB

On Fri, Jan 12, 2024 at 10:45:37AM +0100, AngeloGioacchino Del Regno wrote:
> Since there is no user yet, rename the only interrupt of this device
> to "PD-IRQB", avoiding underscores.

It is primarily node and property names that have this recommendation,
not so much -names values.

If there is only 1 interrupt, I'd just drop the name.

> Signed-off-by: AngeloGioacchino Del Regno <[email protected]>
> ---
> .../devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
> index 053264e60583..0bea23ce2f09 100644
> --- a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
> +++ b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
> @@ -24,7 +24,7 @@ properties:
>
> interrupt-names:
> items:
> - - const: PD_IRQB
> + - const: PD-IRQB
>
> connector:
> type: object
> @@ -58,7 +58,7 @@ examples:
> tcpc {
> compatible = "mediatek,mt6360-tcpc";
> interrupts-extended = <&gpio26 3 IRQ_TYPE_LEVEL_LOW>;
> - interrupt-names = "PD_IRQB";
> + interrupt-names = "PD-IRQB";
>
> connector {
> compatible = "usb-c-connector";
> --
> 2.43.0
>

Subject: Re: [PATCH 1/2] dt-bindings: usb: mt6360-tcpc: Rename IRQ to PD-IRQB

Il 12/01/24 15:20, Rob Herring ha scritto:
> On Fri, Jan 12, 2024 at 10:45:37AM +0100, AngeloGioacchino Del Regno wrote:
>> Since there is no user yet, rename the only interrupt of this device
>> to "PD-IRQB", avoiding underscores.
>
> It is primarily node and property names that have this recommendation,
> not so much -names values.
>
> If there is only 1 interrupt, I'd just drop the name.
>

Yeah, you're totally right. I'll just drop it.

Thanks!
Angelo

>> Signed-off-by: AngeloGioacchino Del Regno <[email protected]>
>> ---
>> .../devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
>> index 053264e60583..0bea23ce2f09 100644
>> --- a/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
>> +++ b/Documentation/devicetree/bindings/usb/mediatek,mt6360-tcpc.yaml
>> @@ -24,7 +24,7 @@ properties:
>>
>> interrupt-names:
>> items:
>> - - const: PD_IRQB
>> + - const: PD-IRQB
>>
>> connector:
>> type: object
>> @@ -58,7 +58,7 @@ examples:
>> tcpc {
>> compatible = "mediatek,mt6360-tcpc";
>> interrupts-extended = <&gpio26 3 IRQ_TYPE_LEVEL_LOW>;
>> - interrupt-names = "PD_IRQB";
>> + interrupt-names = "PD-IRQB";
>>
>> connector {
>> compatible = "usb-c-connector";
>> --
>> 2.43.0
>>