2024-02-03 14:42:20

by Dimitri Fedrau

[permalink] [raw]
Subject: Re: [PATCH] iio: humidity: hdc3020: add threshold events support

Am Sat, Feb 03, 2024 at 10:30:09AM +0100 schrieb Javier Carrasco:
> Hi Dimitri,
>
Hi Javier,

> > + /* Supported temperature range is from –40 to 125 degree celsius */
> Should that not be val < -40?
yes, you are right. Will fix it.
> > + if (val < -45 || val > 125)
> > + return -EINVAL;
> > +

Best regards,
Dimitri


2024-02-03 15:53:49

by Javier Carrasco

[permalink] [raw]
Subject: Re: [PATCH] iio: humidity: hdc3020: add threshold events support

On 03.02.24 15:42, Dimitri Fedrau wrote:
> Am Sat, Feb 03, 2024 at 10:30:09AM +0100 schrieb Javier Carrasco:
>> Hi Dimitri,
>>
> Hi Javier,
>
>>> + /* Supported temperature range is from –40 to 125 degree celsius */
>> Should that not be val < -40?
> yes, you are right. Will fix it.
>>> + if (val < -45 || val > 125)
>>> + return -EINVAL;
>>> +
>
> Best regards,
> Dimitri

When at it, could you please rename the hdc3020_id variable you added to
the probe function? It shadows the i2c_device_id global variable (it is
not used in the probe function, but there is no need to use the exact
same name), and given that it is in the hdc3020_probe function,
mentioning the device name again is kind of redundant. Something like
just "id" or "dev_id" would suffice.

Best regards,
Javier Carrasco

2024-02-03 16:08:55

by Dimitri Fedrau

[permalink] [raw]
Subject: Re: [PATCH] iio: humidity: hdc3020: add threshold events support

Am Sat, Feb 03, 2024 at 04:53:33PM +0100 schrieb Javier Carrasco:
> On 03.02.24 15:42, Dimitri Fedrau wrote:
> > Am Sat, Feb 03, 2024 at 10:30:09AM +0100 schrieb Javier Carrasco:
> >> Hi Dimitri,
> >>
> > Hi Javier,
> >
> >>> + /* Supported temperature range is from –40 to 125 degree celsius */
> >> Should that not be val < -40?
> > yes, you are right. Will fix it.
> >>> + if (val < -45 || val > 125)
> >>> + return -EINVAL;
> >>> +
> >
> > Best regards,
> > Dimitri
>
> When at it, could you please rename the hdc3020_id variable you added to
> the probe function? It shadows the i2c_device_id global variable (it is
> not used in the probe function, but there is no need to use the exact
> same name), and given that it is in the hdc3020_probe function,
> mentioning the device name again is kind of redundant. Something like
> just "id" or "dev_id" would suffice.
>
Sure.

Best regards,
Dimitri