2024-02-01 08:44:32

by Kunwu Chan

[permalink] [raw]
Subject: [PATCH v2] btrfs: Simplify the allocation of slab caches in btrfs_delayed_inode_init

Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
to simplify the creation of SLAB caches.
Make the code cleaner and more readable.

Signed-off-by: Kunwu Chan <[email protected]>
---
Changes in v2:
- Update commit msg only, no functional changes
---
fs/btrfs/delayed-inode.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)

diff --git a/fs/btrfs/delayed-inode.c b/fs/btrfs/delayed-inode.c
index 08102883f560..8c748c6cdf6d 100644
--- a/fs/btrfs/delayed-inode.c
+++ b/fs/btrfs/delayed-inode.c
@@ -28,11 +28,7 @@ static struct kmem_cache *delayed_node_cache;

int __init btrfs_delayed_inode_init(void)
{
- delayed_node_cache = kmem_cache_create("btrfs_delayed_node",
- sizeof(struct btrfs_delayed_node),
- 0,
- SLAB_MEM_SPREAD,
- NULL);
+ delayed_node_cache = KMEM_CACHE(btrfs_delayed_node, SLAB_MEM_SPREAD);
if (!delayed_node_cache)
return -ENOMEM;
return 0;
--
2.39.2



2024-02-01 13:29:32

by Markus Elfring

[permalink] [raw]
Subject: Re: [v2] btrfs: Simplify the allocation of slab caches in btrfs_delayed_inode_init

> Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
> to simplify the creation of SLAB caches.
> Make the code cleaner and more readable.

* Please replace the word “new” by a reference to the commit 8eb8284b412906181357c2b0110d879d5af95e52
("usercopy: Prepare for usercopy whitelisting").

See also related background information from 2017-06-10.

* How does your response fit to the repetition of improvable change descriptions?

Example:
[PATCH] btrfs: Simplify the allocation of slab caches in btrfs_transaction_init
https://lore.kernel.org/lkml/[email protected]/
https://lkml.org/lkml/2024/2/1/387

* Would you like to group similar source code transformations
into patch series?


Regards,
Markus

2024-02-05 16:04:52

by David Sterba

[permalink] [raw]
Subject: Re: [PATCH v2] btrfs: Simplify the allocation of slab caches in btrfs_delayed_inode_init

On Thu, Feb 01, 2024 at 04:44:06PM +0800, Kunwu Chan wrote:
> Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
> to simplify the creation of SLAB caches.
> Make the code cleaner and more readable.
>
> Signed-off-by: Kunwu Chan <[email protected]>
> ---
> Changes in v2:
> - Update commit msg only, no functional changes

Please convert all kmem_cache_create calls where the KMEM_CACHE macro is
suitable, ie the cache name and the structure name match.

2024-02-19 09:00:39

by Kunwu Chan

[permalink] [raw]
Subject: Re: [PATCH v2] btrfs: Simplify the allocation of slab caches in btrfs_delayed_inode_init

Thanks for your reply.

On 2024/2/6 00:04, David Sterba wrote:
> On Thu, Feb 01, 2024 at 04:44:06PM +0800, Kunwu Chan wrote:
>> Use the new KMEM_CACHE() macro instead of direct kmem_cache_create
>> to simplify the creation of SLAB caches.
>> Make the code cleaner and more readable.
>>
>> Signed-off-by: Kunwu Chan <[email protected]>
>> ---
>> Changes in v2:
>> - Update commit msg only, no functional changes
>
> Please convert all kmem_cache_create calls where the KMEM_CACHE macro is
> suitable, ie the cache name and the structure name match.
I'll do this by a patch series.
--
Thanks,
Kunwu