2023-11-29 12:50:47

by Wenjia Zhang

[permalink] [raw]
Subject: Re: [PATCH net-next v2 1/7] net/smc: Rename some variable 'fce' to 'fce_v2x' for clarity



On 24.11.23 15:42, Wen Gu wrote:
> Rename some smc_clc_first_contact_ext_v2x type variables to 'fce_v2x'
> to distinguish them from smc_clc_first_contact_ext type variables.
>
> Signed-off-by: Wen Gu <[email protected]>
> ---
> net/smc/smc_clc.c | 26 +++++++++++++-------------
> 1 file changed, 13 insertions(+), 13 deletions(-)
>
> diff --git a/net/smc/smc_clc.c b/net/smc/smc_clc.c
> index 0fda515..c41a249 100644
> --- a/net/smc/smc_clc.c
> +++ b/net/smc/smc_clc.c
> @@ -418,15 +418,15 @@ static bool smc_clc_msg_prop_valid(struct smc_clc_msg_proposal *pclc)
> return true;
> }
>
> -static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce,
> +static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce_v2x,
> struct smc_init_info *ini)

Since this function is only used by v2.x, IMO, this function name could
also be changed to e.g. smc_clc_fill_fce_v2x.
> {
> - int ret = sizeof(*fce);
> + int ret = sizeof(*fce_v2x);
>
> - memset(fce, 0, sizeof(*fce));
> - fce->fce_v2_base.os_type = SMC_CLC_OS_LINUX;
> - fce->fce_v2_base.release = ini->release_nr;
> - memcpy(fce->fce_v2_base.hostname, smc_hostname, sizeof(smc_hostname));
> + memset(fce_v2x, 0, sizeof(*fce_v2x));
> + fce_v2x->fce_v2_base.os_type = SMC_CLC_OS_LINUX;
> + fce_v2x->fce_v2_base.release = ini->release_nr;
> + memcpy(fce_v2x->fce_v2_base.hostname, smc_hostname, sizeof(smc_hostname));
> if (ini->is_smcd && ini->release_nr < SMC_RELEASE_1) {
> ret = sizeof(struct smc_clc_first_contact_ext);
> goto out;
> @@ -434,8 +434,8 @@ static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce,
>
> if (ini->release_nr >= SMC_RELEASE_1) {
> if (!ini->is_smcd) {
> - fce->max_conns = ini->max_conns;
> - fce->max_links = ini->max_links;
> + fce_v2x->max_conns = ini->max_conns;
> + fce_v2x->max_links = ini->max_links;
> }
> }
>
> @@ -1003,8 +1003,8 @@ static int smc_clc_send_confirm_accept(struct smc_sock *smc,
> int first_contact, u8 version,
> u8 *eid, struct smc_init_info *ini)
> {
> + struct smc_clc_first_contact_ext_v2x fce_v2x;
> struct smc_connection *conn = &smc->conn;
> - struct smc_clc_first_contact_ext_v2x fce;
> struct smc_clc_msg_accept_confirm *clc;
> struct smc_clc_fce_gid_ext gle;
> struct smc_clc_msg_trail trl;
> @@ -1037,7 +1037,7 @@ static int smc_clc_send_confirm_accept(struct smc_sock *smc,
> memcpy(clc_v2->d1.eid, eid, SMC_MAX_EID_LEN);
> len = SMCD_CLC_ACCEPT_CONFIRM_LEN_V2;
> if (first_contact) {
> - fce_len = smc_clc_fill_fce(&fce, ini);
> + fce_len = smc_clc_fill_fce(&fce_v2x, ini);
> len += fce_len;
> }
> clc_v2->hdr.length = htons(len);
> @@ -1083,9 +1083,9 @@ static int smc_clc_send_confirm_accept(struct smc_sock *smc,
> memcpy(clc_v2->r1.eid, eid, SMC_MAX_EID_LEN);
> len = SMCR_CLC_ACCEPT_CONFIRM_LEN_V2;
> if (first_contact) {
> - fce_len = smc_clc_fill_fce(&fce, ini);
> + fce_len = smc_clc_fill_fce(&fce_v2x, ini);
> len += fce_len;
> - fce.fce_v2_base.v2_direct = !link->lgr->uses_gateway;
> + fce_v2x.fce_v2_base.v2_direct = !link->lgr->uses_gateway;
> if (clc->hdr.type == SMC_CLC_CONFIRM) {
> memset(&gle, 0, sizeof(gle));
> gle.gid_cnt = ini->smcrv2.gidlist.len;
> @@ -1112,7 +1112,7 @@ static int smc_clc_send_confirm_accept(struct smc_sock *smc,
> SMCR_CLC_ACCEPT_CONFIRM_LEN) -
> sizeof(trl);
> if (version > SMC_V1 && first_contact) {
> - vec[i].iov_base = &fce;
> + vec[i].iov_base = &fce_v2x;
> vec[i++].iov_len = fce_len;
> if (!conn->lgr->is_smcd) {
> if (clc->hdr.type == SMC_CLC_CONFIRM) {


2023-11-30 11:02:26

by Wen Gu

[permalink] [raw]
Subject: Re: [PATCH net-next v2 1/7] net/smc: Rename some variable 'fce' to 'fce_v2x' for clarity



On 2023/11/29 20:50, Wenjia Zhang wrote:
>
>
> On 24.11.23 15:42, Wen Gu wrote:
>> Rename some smc_clc_first_contact_ext_v2x type variables to 'fce_v2x'
>> to distinguish them from smc_clc_first_contact_ext type variables.
>>
>> Signed-off-by: Wen Gu <[email protected]>
>> ---
>>   net/smc/smc_clc.c | 26 +++++++++++++-------------
>>   1 file changed, 13 insertions(+), 13 deletions(-)
>>
>> diff --git a/net/smc/smc_clc.c b/net/smc/smc_clc.c
>> index 0fda515..c41a249 100644
>> --- a/net/smc/smc_clc.c
>> +++ b/net/smc/smc_clc.c
>> @@ -418,15 +418,15 @@ static bool smc_clc_msg_prop_valid(struct smc_clc_msg_proposal *pclc)
>>       return true;
>>   }
>> -static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce,
>> +static int smc_clc_fill_fce(struct smc_clc_first_contact_ext_v2x *fce_v2x,
>>                   struct smc_init_info *ini)
>
> Since this function is only used by v2.x, IMO, this function name could also be changed to e.g. smc_clc_fill_fce_v2x.

Thank you, Wenjia. The function name will also be changed.