2017-11-20 20:16:28

by walter harms

[permalink] [raw]
Subject: Re: [PATCH] USB: serial: iuu_phoenix: remove redundant assignment of DIV to itself



Am 20.11.2017 18:40, schrieb Colin King:
> From: Colin Ian King <[email protected]>
>
> The assignment of DIV to itself is redundant and can be removed.
>
> Signed-off-by: Colin Ian King <[email protected]>
> ---
> drivers/usb/serial/iuu_phoenix.c | 1 -
> 1 file changed, 1 deletion(-)
>
> diff --git a/drivers/usb/serial/iuu_phoenix.c b/drivers/usb/serial/iuu_phoenix.c
> index 397a8012ffa3..62c91e360baf 100644
> --- a/drivers/usb/serial/iuu_phoenix.c
> +++ b/drivers/usb/serial/iuu_phoenix.c
> @@ -472,7 +472,6 @@ static int iuu_clk(struct usb_serial_port *port, int dwFrq)
> }
> }
> P2 = ((P - PO) / 2) - 4;
> - DIV = DIV;
> PUMP = 0x04;
> PBmsb = (P2 >> 8 & 0x03);
> PBlsb = P2 & 0xFF;

These all all-upper-case stuff makes me a bit nervous. Normally this
is reserved for #define ( I assume that the programmer refers to
the original documentation) a point to change ?

btw: i noticed int frq = (int)dwFrq;
since dwFrq is already an in, the cast is useless.

just ym 2 cents,

re,
wh




From 1584607703111798996@xxx Mon Nov 20 17:41:08 +0000 2017
X-GM-THRID: 1584607703111798996
X-Gmail-Labels: Inbox,Category Forums,HistoricalUnread