2018-12-29 21:38:54

by Valentin Vidic

[permalink] [raw]
Subject: [PATCH] n_tty: update comment for WAKEUP_CHARS define

Give a better descriptions of what WAKEUP_CHARS represents.

Signed-off-by: Valentin Vidic <[email protected]>
---
drivers/tty/n_tty.c | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
index 3ad460219fd6..1dfbd45746da 100644
--- a/drivers/tty/n_tty.c
+++ b/drivers/tty/n_tty.c
@@ -50,8 +50,10 @@
#include <linux/ratelimit.h>
#include <linux/vmalloc.h>

-
-/* number of characters left in xmit buffer before select has we have room */
+/*
+ * Until this number of characters is queued in the xmit buffer, select will
+ * return "we have room for writes".
+ */
#define WAKEUP_CHARS 256

/*
--
2.20.1



2019-01-02 07:18:26

by Jiri Slaby

[permalink] [raw]
Subject: Re: [PATCH] n_tty: update comment for WAKEUP_CHARS define

On 29. 12. 18, 13:48, Valentin Vidic wrote:
> Give a better descriptions of what WAKEUP_CHARS represents.
>
> Signed-off-by: Valentin Vidic <[email protected]>

I am not a native speaker, but this is much better than the current text.

Acked-by: Jiri Slaby <[email protected]>

BTW this text is copy&pasted from/to all the other WAKEUP_CHARS
locations. Care to fix them all?

> ---
> drivers/tty/n_tty.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/tty/n_tty.c b/drivers/tty/n_tty.c
> index 3ad460219fd6..1dfbd45746da 100644
> --- a/drivers/tty/n_tty.c
> +++ b/drivers/tty/n_tty.c
> @@ -50,8 +50,10 @@
> #include <linux/ratelimit.h>
> #include <linux/vmalloc.h>
>
> -
> -/* number of characters left in xmit buffer before select has we have room */
> +/*
> + * Until this number of characters is queued in the xmit buffer, select will
> + * return "we have room for writes".
> + */
> #define WAKEUP_CHARS 256
>
> /*
>

thanks,
--
js
suse labs

2019-01-02 10:51:39

by Valentin Vidic

[permalink] [raw]
Subject: Re: [PATCH] n_tty: update comment for WAKEUP_CHARS define

On Wed, Jan 02, 2019 at 07:48:42AM +0100, Jiri Slaby wrote:
> On 29. 12. 18, 13:48, Valentin Vidic wrote:
> > Give a better descriptions of what WAKEUP_CHARS represents.
> >
> > Signed-off-by: Valentin Vidic <[email protected]>
>
> I am not a native speaker, but this is much better than the current text.
>
> Acked-by: Jiri Slaby <[email protected]>
>
> BTW this text is copy&pasted from/to all the other WAKEUP_CHARS
> locations. Care to fix them all?

Yes, I've seen other instances of WAKEUP_CHARS but they don't look like
the same thing, for example:

rocket_int.h:/* number of characters left in xmit buffer before we ask for more */
rocket_int.h:#define WAKEUP_CHARS 256

rocket.c: if (info->xmit_cnt < WAKEUP_CHARS) {
rocket.c: tty_wakeup(tty);

Maybe the instance in n_tty.c could use a better name instead?

--
Valentin