2022-03-01 15:16:54

by Geert Uytterhoeven

[permalink] [raw]
Subject: [PATCH] base: soc: Make soc_device_match() simpler and easier to read

The function soc_device_match() is difficult to read for various
reasons:
- There are two loop conditions using different styles: "while (...)"
(which is BTW always true) vs. "if ... break",
- The are two return condition using different logic: "if ... return
foo" vs. "if ... else return bar".

Make the code easier to read by:
1. Removing the always-true "!ret" loop condition, and dropping the
now unneeded pre-initialization of "ret",
2. Converting "if ... break" to a proper "while (...)" loop condition,
3. Inverting the logic of the second return condition.

Signed-off-by: Geert Uytterhoeven <[email protected]>
---
drivers/base/soc.c | 14 ++++++--------
1 file changed, 6 insertions(+), 8 deletions(-)

diff --git a/drivers/base/soc.c b/drivers/base/soc.c
index 0af5363a582c36dd..22130b5f789d9d7e 100644
--- a/drivers/base/soc.c
+++ b/drivers/base/soc.c
@@ -241,15 +241,13 @@ static int soc_device_match_one(struct device *dev, void *arg)
const struct soc_device_attribute *soc_device_match(
const struct soc_device_attribute *matches)
{
- int ret = 0;
+ int ret;

if (!matches)
return NULL;

- while (!ret) {
- if (!(matches->machine || matches->family ||
- matches->revision || matches->soc_id))
- break;
+ while (matches->machine || matches->family || matches->revision ||
+ matches->soc_id) {
ret = bus_for_each_dev(&soc_bus_type, NULL, (void *)matches,
soc_device_match_one);
if (ret < 0 && early_soc_dev_attr)
@@ -257,10 +255,10 @@ const struct soc_device_attribute *soc_device_match(
matches);
if (ret < 0)
return NULL;
- if (!ret)
- matches++;
- else
+ if (ret)
return matches;
+
+ matches++;
}
return NULL;
}
--
2.25.1


2022-03-01 20:28:30

by Arnd Bergmann

[permalink] [raw]
Subject: Re: [PATCH] base: soc: Make soc_device_match() simpler and easier to read

On Tue, Mar 1, 2022 at 12:10 PM Geert Uytterhoeven
<[email protected]> wrote:
>
> The function soc_device_match() is difficult to read for various
> reasons:
> - There are two loop conditions using different styles: "while (...)"
> (which is BTW always true) vs. "if ... break",
> - The are two return condition using different logic: "if ... return
> foo" vs. "if ... else return bar".
>
> Make the code easier to read by:
> 1. Removing the always-true "!ret" loop condition, and dropping the
> now unneeded pre-initialization of "ret",
> 2. Converting "if ... break" to a proper "while (...)" loop condition,
> 3. Inverting the logic of the second return condition.
>
> Signed-off-by: Geert Uytterhoeven <[email protected]>
> ---

Reviewed-by: Arnd Bergmann <[email protected]>