2013-05-24 23:24:01

by Hartley Sweeten

[permalink] [raw]
Subject: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io

The mmio_base is an ioremap'ed memory resource. The normal memory
io functions should be used not the __raw_* versions.

Signed-off-by: H Hartley Sweeten <[email protected]>
Cc: Arnd Bergmann <[email protected]>
Cc: Greg Kroah-Hartman <[email protected]>
Cc: Ryan Mallon <[email protected]>
Cc: Matthieu Crapet <[email protected]>
---
drivers/misc/ep93xx_pwm.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/misc/ep93xx_pwm.c b/drivers/misc/ep93xx_pwm.c
index 36370b4..af01fb9 100644
--- a/drivers/misc/ep93xx_pwm.c
+++ b/drivers/misc/ep93xx_pwm.c
@@ -42,13 +42,13 @@ struct ep93xx_pwm {
static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
unsigned int val, unsigned int off)
{
- __raw_writel(val, pwm->mmio_base + off);
+ writel(val, pwm->mmio_base + off);
}

static inline unsigned int ep93xx_pwm_readl(struct ep93xx_pwm *pwm,
unsigned int off)
{
- return __raw_readl(pwm->mmio_base + off);
+ return readl(pwm->mmio_base + off);
}

static inline void ep93xx_pwm_write_tc(struct ep93xx_pwm *pwm, u16 value)
--
1.8.1.4


2013-05-27 15:18:49

by Arnd Bergmann

[permalink] [raw]
Subject: Re: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io

On Saturday 25 May 2013, H Hartley Sweeten wrote:
> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
> static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
> unsigned int val, unsigned int off)
> {
> - __raw_writel(val, pwm->mmio_base + off);
> + writel(val, pwm->mmio_base + off);
> }

Just an idea: since you are adding the writel in a lot of places in subsequent
patches, you could rename 'mmio_base' to the shorter 'base' first, which would
make the resulting code actually smaller.

Arnd

2013-05-27 16:20:35

by Hartley Sweeten

[permalink] [raw]
Subject: RE: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io

On Monday, May 27, 2013 8:18 AM, Arnd Bergmann wrote:
> On Saturday 25 May 2013, H Hartley Sweeten wrote:
>> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
>> static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
>> unsigned int val, unsigned int off)
>> {
>> - __raw_writel(val, pwm->mmio_base + off);
>> + writel(val, pwm->mmio_base + off);
>> }
>
> Just an idea: since you are adding the writel in a lot of places in subsequent
> patches, you could rename 'mmio_base' to the shorter 'base' first, which would
> make the resulting code actually smaller.

Hmm.. It would make the source file a bit smaller but the compiled size would
be the same.

But, I'll probably rename the variable when I convert this driver to the PWM
framework.

Thanks,
Hartley-

2013-05-27 17:07:20

by Arnd Bergmann

[permalink] [raw]
Subject: Re: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io

On Monday 27 May 2013, H Hartley Sweeten wrote:
> On Monday, May 27, 2013 8:18 AM, Arnd Bergmann wrote:
> > On Saturday 25 May 2013, H Hartley Sweeten wrote:
> >> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
> >> static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
> >> unsigned int val, unsigned int off)
> >> {
> >> - __raw_writel(val, pwm->mmio_base + off);
> >> + writel(val, pwm->mmio_base + off);
> >> }
> >
> > Just an idea: since you are adding the writel in a lot of places in subsequent
> > patches, you could rename 'mmio_base' to the shorter 'base' first, which would
> > make the resulting code actually smaller.
>
> Hmm.. It would make the source file a bit smaller but the compiled size would
> be the same.

Right.

> But, I'll probably rename the variable when I convert this driver to the PWM
> framework.

Ok.

Arnd