2024-06-02 08:49:52

by Erick Archer

[permalink] [raw]
Subject: [PATCH] auxdisplay: Use sizeof(*pointer) instead of sizeof(type)

It is preferred to use sizeof(*pointer) instead of sizeof(type)
due to the type of the variable can change and one needs not
change the former (unlike the latter). This patch has no effect
on runtime behavior.

Signed-off-by: Erick Archer <[email protected]>
---
drivers/auxdisplay/arm-charlcd.c | 2 +-
drivers/auxdisplay/hd44780.c | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/auxdisplay/arm-charlcd.c b/drivers/auxdisplay/arm-charlcd.c
index 0b1c99cca733..a7eae99a48f7 100644
--- a/drivers/auxdisplay/arm-charlcd.c
+++ b/drivers/auxdisplay/arm-charlcd.c
@@ -270,7 +270,7 @@ static int __init charlcd_probe(struct platform_device *pdev)
struct charlcd *lcd;
struct resource *res;

- lcd = kzalloc(sizeof(struct charlcd), GFP_KERNEL);
+ lcd = kzalloc(sizeof(*lcd), GFP_KERNEL);
if (!lcd)
return -ENOMEM;

diff --git a/drivers/auxdisplay/hd44780.c b/drivers/auxdisplay/hd44780.c
index 7ac0b1b1d548..025dc6855cb2 100644
--- a/drivers/auxdisplay/hd44780.c
+++ b/drivers/auxdisplay/hd44780.c
@@ -230,7 +230,7 @@ static int hd44780_probe(struct platform_device *pdev)
if (!lcd)
goto fail1;

- hd = kzalloc(sizeof(struct hd44780), GFP_KERNEL);
+ hd = kzalloc(sizeof(*hd), GFP_KERNEL);
if (!hd)
goto fail2;

--
2.25.1



2024-06-03 07:53:35

by Geert Uytterhoeven

[permalink] [raw]
Subject: Re: [PATCH] auxdisplay: Use sizeof(*pointer) instead of sizeof(type)

On Sun, Jun 2, 2024 at 10:49 AM Erick Archer <[email protected]> wrote:
> It is preferred to use sizeof(*pointer) instead of sizeof(type)
> due to the type of the variable can change and one needs not
> change the former (unlike the latter). This patch has no effect
> on runtime behavior.
>
> Signed-off-by: Erick Archer <[email protected]>

Reviewed-by: Geert Uytterhoeven <[email protected]>

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds

2024-06-03 19:50:26

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH] auxdisplay: Use sizeof(*pointer) instead of sizeof(type)

On Mon, Jun 03, 2024 at 09:52:57AM +0200, Geert Uytterhoeven wrote:
> On Sun, Jun 2, 2024 at 10:49 AM Erick Archer <[email protected]> wrote:
> > It is preferred to use sizeof(*pointer) instead of sizeof(type)
> > due to the type of the variable can change and one needs not
> > change the former (unlike the latter). This patch has no effect
> > on runtime behavior.
> >
> > Signed-off-by: Erick Archer <[email protected]>
>
> Reviewed-by: Geert Uytterhoeven <[email protected]>

Pushed to my review and testing queue, thanks!

--
With Best Regards,
Andy Shevchenko