2022-02-22 15:14:55

by Miaohe Lin

[permalink] [raw]
Subject: [PATCH] mm/hugetlb: use helper macro __ATTR_RW

Use helper macro __ATTR_RW to define HSTATE_ATTR to make code more
clear. Minor readability improvement.

Signed-off-by: Miaohe Lin <[email protected]>
---
mm/hugetlb.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/mm/hugetlb.c b/mm/hugetlb.c
index 1f0cca036f7f..c0405f3c8413 100644
--- a/mm/hugetlb.c
+++ b/mm/hugetlb.c
@@ -3498,8 +3498,7 @@ static int demote_pool_huge_page(struct hstate *h, nodemask_t *nodes_allowed)
static struct kobj_attribute _name##_attr = __ATTR_WO(_name)

#define HSTATE_ATTR(_name) \
- static struct kobj_attribute _name##_attr = \
- __ATTR(_name, 0644, _name##_show, _name##_store)
+ static struct kobj_attribute _name##_attr = __ATTR_RW(_name)

static struct kobject *hugepages_kobj;
static struct kobject *hstate_kobjs[HUGE_MAX_HSTATE];
--
2.23.0


2022-02-23 03:16:14

by Mike Kravetz

[permalink] [raw]
Subject: Re: [PATCH] mm/hugetlb: use helper macro __ATTR_RW

On 2/22/22 03:27, Miaohe Lin wrote:
> Use helper macro __ATTR_RW to define HSTATE_ATTR to make code more
> clear. Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <[email protected]>
> ---
> mm/hugetlb.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)

Thanks!

I should have noticed and changed that when adding HSTATE_ATTR_WO.

Reviewed-by: Mike Kravetz <[email protected]>
--
Mike Kravetz

>
> diff --git a/mm/hugetlb.c b/mm/hugetlb.c
> index 1f0cca036f7f..c0405f3c8413 100644
> --- a/mm/hugetlb.c
> +++ b/mm/hugetlb.c
> @@ -3498,8 +3498,7 @@ static int demote_pool_huge_page(struct hstate *h, nodemask_t *nodes_allowed)
> static struct kobj_attribute _name##_attr = __ATTR_WO(_name)
>
> #define HSTATE_ATTR(_name) \
> - static struct kobj_attribute _name##_attr = \
> - __ATTR(_name, 0644, _name##_show, _name##_store)
> + static struct kobj_attribute _name##_attr = __ATTR_RW(_name)
>
> static struct kobject *hugepages_kobj;
> static struct kobject *hstate_kobjs[HUGE_MAX_HSTATE];

2022-02-24 10:49:59

by Muchun Song

[permalink] [raw]
Subject: Re: [PATCH] mm/hugetlb: use helper macro __ATTR_RW

On Tue, Feb 22, 2022 at 7:28 PM Miaohe Lin <[email protected]> wrote:
>
> Use helper macro __ATTR_RW to define HSTATE_ATTR to make code more
> clear. Minor readability improvement.
>
> Signed-off-by: Miaohe Lin <[email protected]>

More simple.

Reviewed-by: Muchun Song <[email protected]>