2023-02-08 17:27:20

by Krzysztof Kozlowski

[permalink] [raw]
Subject: [RFT PATCH 1/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Midas

The GPIOs properties should end with "gpios" suffix and Linux gpiolib
already handles both names, so switch to preferred one.

While touching the lines, replace open-coded GPIO_ACTIVE_HIGH flag.

Signed-off-by: Krzysztof Kozlowski <[email protected]>
---
arch/arm/boot/dts/exynos4412-midas.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/boot/dts/exynos4412-midas.dtsi b/arch/arm/boot/dts/exynos4412-midas.dtsi
index d5074fa57142..525f945c4b91 100644
--- a/arch/arm/boot/dts/exynos4412-midas.dtsi
+++ b/arch/arm/boot/dts/exynos4412-midas.dtsi
@@ -653,8 +653,8 @@ wm1811: audio-codec@1a {
CPVDD-supply = <&vbatt_reg>;
SPKVDD1-supply = <&vbatt_reg>;
SPKVDD2-supply = <&vbatt_reg>;
- wlf,ldo1ena = <&gpj0 4 0>;
- wlf,ldo2ena = <&gpj0 4 0>;
+ wlf,ldo1ena-gpios = <&gpj0 4 GPIO_ACTIVE_HIGH>;
+ wlf,ldo2ena-gpios = <&gpj0 4 GPIO_ACTIVE_HIGH>;
};
};

--
2.34.1



2023-02-08 17:27:22

by Krzysztof Kozlowski

[permalink] [raw]
Subject: [RFT PATCH 2/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Arndale

The GPIOs properties should end with "gpios" suffix and Linux gpiolib
already handles both names, so switch to preferred one.

Signed-off-by: Krzysztof Kozlowski <[email protected]>
---
arch/arm/boot/dts/exynos5250-arndale.dts | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/boot/dts/exynos5250-arndale.dts b/arch/arm/boot/dts/exynos5250-arndale.dts
index 6134bc9c8212..2e3da5670bc2 100644
--- a/arch/arm/boot/dts/exynos5250-arndale.dts
+++ b/arch/arm/boot/dts/exynos5250-arndale.dts
@@ -537,8 +537,8 @@ wm1811: audio-codec@1a {
SPKVDD1-supply = <&main_dc_reg>;
SPKVDD2-supply = <&main_dc_reg>;

- wlf,ldo1ena = <&gpb0 0 GPIO_ACTIVE_HIGH>;
- wlf,ldo2ena = <&gpb0 1 GPIO_ACTIVE_HIGH>;
+ wlf,ldo1ena-gpios = <&gpb0 0 GPIO_ACTIVE_HIGH>;
+ wlf,ldo2ena-gpios = <&gpb0 1 GPIO_ACTIVE_HIGH>;
};
};

--
2.34.1


2023-02-08 17:27:30

by Krzysztof Kozlowski

[permalink] [raw]
Subject: [RFT PATCH 3/3] ARM: dts: s5pv210: add "gpios" suffix to wlf,ldo1ena on Aries

The GPIOs properties should end with "gpios" suffix and Linux gpiolib
already handles both names, so switch to preferred one.

Signed-off-by: Krzysztof Kozlowski <[email protected]>
---
arch/arm/boot/dts/s5pv210-aries.dtsi | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/boot/dts/s5pv210-aries.dtsi b/arch/arm/boot/dts/s5pv210-aries.dtsi
index 964c5fe51755..f628d3660493 100644
--- a/arch/arm/boot/dts/s5pv210-aries.dtsi
+++ b/arch/arm/boot/dts/s5pv210-aries.dtsi
@@ -135,8 +135,8 @@ wm8994: audio-codec@1a {
0xa101 0x0100 0x8100 0x0100 0x0100
0x0100>;

- wlf,ldo1ena = <&gpf3 4 GPIO_ACTIVE_HIGH>;
- wlf,ldo2ena = <&gpf3 4 GPIO_ACTIVE_HIGH>;
+ wlf,ldo1ena-gpios = <&gpf3 4 GPIO_ACTIVE_HIGH>;
+ wlf,ldo2ena-gpios = <&gpf3 4 GPIO_ACTIVE_HIGH>;

wlf,lineout1-se;
wlf,lineout2-se;
--
2.34.1


2023-02-09 07:18:18

by Henrik Grimler

[permalink] [raw]
Subject: Re: [RFT PATCH 1/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Midas

On Wed, Feb 08, 2023 at 06:26:32PM +0100, Krzysztof Kozlowski wrote:
> The GPIOs properties should end with "gpios" suffix and Linux gpiolib
> already handles both names, so switch to preferred one.
>
> While touching the lines, replace open-coded GPIO_ACTIVE_HIGH flag.
>
> Signed-off-by: Krzysztof Kozlowski <[email protected]>

Tested-by: Henrik Grimler <[email protected]>

Audio still works fine on i9300, and there are no new warnings/errors
in dmesg.

Best regards,
Henrik Grimler

> ---
> arch/arm/boot/dts/exynos4412-midas.dtsi | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/boot/dts/exynos4412-midas.dtsi b/arch/arm/boot/dts/exynos4412-midas.dtsi
> index d5074fa57142..525f945c4b91 100644
> --- a/arch/arm/boot/dts/exynos4412-midas.dtsi
> +++ b/arch/arm/boot/dts/exynos4412-midas.dtsi
> @@ -653,8 +653,8 @@ wm1811: audio-codec@1a {
> CPVDD-supply = <&vbatt_reg>;
> SPKVDD1-supply = <&vbatt_reg>;
> SPKVDD2-supply = <&vbatt_reg>;
> - wlf,ldo1ena = <&gpj0 4 0>;
> - wlf,ldo2ena = <&gpj0 4 0>;
> + wlf,ldo1ena-gpios = <&gpj0 4 GPIO_ACTIVE_HIGH>;
> + wlf,ldo2ena-gpios = <&gpj0 4 GPIO_ACTIVE_HIGH>;
> };
> };
>
> --
> 2.34.1
>

2023-02-09 11:11:16

by Krzysztof Kozlowski

[permalink] [raw]
Subject: Re: [RFT PATCH 1/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Midas

On Wed, 8 Feb 2023 18:26:32 +0100, Krzysztof Kozlowski wrote:
> The GPIOs properties should end with "gpios" suffix and Linux gpiolib
> already handles both names, so switch to preferred one.
>
> While touching the lines, replace open-coded GPIO_ACTIVE_HIGH flag.
>
>

Applied, thanks!

[1/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Midas
https://git.kernel.org/krzk/linux/c/0e06b987d1b7469ff1b4f7a68466859f94e7221a
[2/3] ARM: dts: exynos: add "gpios" suffix to wlf,ldo1ena on Arndale
https://git.kernel.org/krzk/linux/c/149a903eceb73b8b8af25e12b552c68aa9991802
[3/3] ARM: dts: s5pv210: add "gpios" suffix to wlf,ldo1ena on Aries
https://git.kernel.org/krzk/linux/c/a81cc43abd23f2769b044b79f4cf58a9ff6e2201

Best regards,
--
Krzysztof Kozlowski <[email protected]>