2023-01-17 14:58:00

by Alok Tiwari

[permalink] [raw]
Subject: [PATCH 6.1] netfilter: Null pointer dereference in nf_tables_updobj

static analyzer detect null pointer dereference case for 'type'
function __nft_obj_type_get() can return NULL value which require to handle
if type is NULL pointer return -ENOENT

Signed-off-by: Alok Tiwari <[email protected]>
---
net/netfilter/nf_tables_api.c | 3 +++
1 file changed, 3 insertions(+)

diff --git a/net/netfilter/nf_tables_api.c b/net/netfilter/nf_tables_api.c
index 3ba8c291fcaa..e20f1de1c216 100644
--- a/net/netfilter/nf_tables_api.c
+++ b/net/netfilter/nf_tables_api.c
@@ -6951,6 +6951,9 @@ static int nf_tables_newobj(struct sk_buff *skb, const struct nfnl_info *info,
return -EOPNOTSUPP;

type = __nft_obj_type_get(objtype);
+ if (!WARN_ON_ONCE(type))
+ return -ENOENT;
+
nft_ctx_init(&ctx, net, skb, info->nlh, family, table, NULL, nla);

return nf_tables_updobj(&ctx, type, nla[NFTA_OBJ_DATA], obj);
--
2.38.1


2023-01-17 14:59:43

by Pablo Neira Ayuso

[permalink] [raw]
Subject: Re: [PATCH 6.1] netfilter: Null pointer dereference in nf_tables_updobj

On Tue, Jan 17, 2023 at 05:45:38AM -0800, Alok Tiwari wrote:
> static analyzer detect null pointer dereference case for 'type'
> function __nft_obj_type_get() can return NULL value which require to handle
> if type is NULL pointer return -ENOENT

This should not ever happen, but it is good to have a failsafe in this
path.

I'll take this into nf.git, thanks.

2023-01-17 15:41:10

by Pablo Neira Ayuso

[permalink] [raw]
Subject: Re: [PATCH 6.1] netfilter: Null pointer dereference in nf_tables_updobj

On Tue, Jan 17, 2023 at 03:17:11PM +0100, Pablo Neira Ayuso wrote:
> On Tue, Jan 17, 2023 at 05:45:38AM -0800, Alok Tiwari wrote:
> > static analyzer detect null pointer dereference case for 'type'
> > function __nft_obj_type_get() can return NULL value which require to handle
> > if type is NULL pointer return -ENOENT
>
> This should not ever happen, but it is good to have a failsafe in this
> path.
>
> I'll take this into nf.git, thanks.

BTW, easier to read:

if (WARN_ON_ONCE(!type))

instead of:

if (!WARN_ON_ONCE(type))

I'll mangle the patch here before applying, unless you prefer to send a v2.