2019-08-05 19:01:10

by Tao Ren

[permalink] [raw]
Subject: [PATCH net-next] net: phy: modify assignment to OR for dev_flags in phy_attach_direct

Modify the assignment to OR when dealing with phydev->dev_flags in
phy_attach_direct function, and this is to make sure dev_flags set in
driver's probe callback won't be lost.

Suggested-by: Andrew Lunn <[email protected]>
CC: Heiner Kallweit <[email protected]>
CC: Vladimir Oltean <[email protected]>
Signed-off-by: Tao Ren <[email protected]>
---
drivers/net/phy/phy_device.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/net/phy/phy_device.c b/drivers/net/phy/phy_device.c
index 6b5cb87f3866..9259eb45c794 100644
--- a/drivers/net/phy/phy_device.c
+++ b/drivers/net/phy/phy_device.c
@@ -1270,7 +1270,7 @@ int phy_attach_direct(struct net_device *dev, struct phy_device *phydev,
phydev_err(phydev, "error creating 'phy_standalone' sysfs entry\n");
}

- phydev->dev_flags = flags;
+ phydev->dev_flags |= flags;

phydev->interface = interface;

--
2.17.1


2019-08-06 21:13:01

by Andrew Lunn

[permalink] [raw]
Subject: Re: [PATCH net-next] net: phy: modify assignment to OR for dev_flags in phy_attach_direct

On Mon, Aug 05, 2019 at 11:55:51AM -0700, Tao Ren wrote:
> Modify the assignment to OR when dealing with phydev->dev_flags in
> phy_attach_direct function, and this is to make sure dev_flags set in
> driver's probe callback won't be lost.
>
> Suggested-by: Andrew Lunn <[email protected]>
> CC: Heiner Kallweit <[email protected]>
> CC: Vladimir Oltean <[email protected]>
> Signed-off-by: Tao Ren <[email protected]>

Reviewed-by: Andrew Lunn <[email protected]>

Andrew

2019-08-13 19:57:59

by Florian Fainelli

[permalink] [raw]
Subject: Re: [PATCH net-next] net: phy: modify assignment to OR for dev_flags in phy_attach_direct

On 8/5/19 11:55 AM, Tao Ren wrote:
> Modify the assignment to OR when dealing with phydev->dev_flags in
> phy_attach_direct function, and this is to make sure dev_flags set in
> driver's probe callback won't be lost.

As Andrew pointed out already, this probably needs to be reworked, but
for now this looks reasonable:

Reviewed-by: Florian Fainelli <[email protected]>
--
Florian