2011-11-15 11:25:56

by Sangwook Lee

[permalink] [raw]
Subject: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

The patch series proposes to rename ath9k_platform.h to "ath_platform.h
This header file handles platform data used only for ath9k,
but it can used by ath6k as well. We can take "wl12xx.h" as
as a example. Please let us change this file name so that
other Atheors WLANs use this file for their own platform data

Signed-off-by: Sangwook Lee <[email protected]>
---
arch/mips/ath79/dev-ar913x-wmac.c | 2 +-
drivers/net/wireless/ath/ath9k/ahb.c | 2 +-
drivers/net/wireless/ath/ath9k/init.c | 2 +-
drivers/net/wireless/ath/ath9k/pci.c | 2 +-
include/linux/{ath9k_platform.h => ath_platform.h} | 0
5 files changed, 4 insertions(+), 4 deletions(-)
rename include/linux/{ath9k_platform.h => ath_platform.h} (100%)

diff --git a/arch/mips/ath79/dev-ar913x-wmac.c b/arch/mips/ath79/dev-ar913x-wmac.c
index 48f425a..bc8869c 100644
--- a/arch/mips/ath79/dev-ar913x-wmac.c
+++ b/arch/mips/ath79/dev-ar913x-wmac.c
@@ -13,7 +13,7 @@
#include <linux/delay.h>
#include <linux/irq.h>
#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>

#include <asm/mach-ath79/ath79.h>
#include <asm/mach-ath79/ar71xx_regs.h>
diff --git a/drivers/net/wireless/ath/ath9k/ahb.c b/drivers/net/wireless/ath/ath9k/ahb.c
index 85a54cd..d84bee6 100644
--- a/drivers/net/wireless/ath/ath9k/ahb.c
+++ b/drivers/net/wireless/ath/ath9k/ahb.c
@@ -18,7 +18,7 @@

#include <linux/nl80211.h>
#include <linux/platform_device.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>
#include "ath9k.h"

static const struct platform_device_id ath9k_platform_id_table[] = {
diff --git a/drivers/net/wireless/ath/ath9k/init.c b/drivers/net/wireless/ath/ath9k/init.c
index af1b325..0c82aea 100644
--- a/drivers/net/wireless/ath/ath9k/init.c
+++ b/drivers/net/wireless/ath/ath9k/init.c
@@ -16,7 +16,7 @@

#include <linux/dma-mapping.h>
#include <linux/slab.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>

#include "ath9k.h"

diff --git a/drivers/net/wireless/ath/ath9k/pci.c b/drivers/net/wireless/ath/ath9k/pci.c
index edb0b4b..2f031b8 100644
--- a/drivers/net/wireless/ath/ath9k/pci.c
+++ b/drivers/net/wireless/ath/ath9k/pci.c
@@ -17,7 +17,7 @@
#include <linux/nl80211.h>
#include <linux/pci.h>
#include <linux/pci-aspm.h>
-#include <linux/ath9k_platform.h>
+#include <linux/ath_platform.h>
#include "ath9k.h"

static DEFINE_PCI_DEVICE_TABLE(ath_pci_id_table) = {
diff --git a/include/linux/ath9k_platform.h b/include/linux/ath_platform.h
similarity index 100%
rename from include/linux/ath9k_platform.h
rename to include/linux/ath_platform.h
--
1.7.4.1



2011-11-15 16:09:23

by Luis R. Rodriguez

[permalink] [raw]
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

On Tue, Nov 15, 2011 at 3:23 AM, Sangwook Lee <[email protected]> wrote:
> The patch series proposes to rename ath9k_platform.h to "ath_platform.h
> This header file handles platform data used only for ath9k,
> but it can used by ath6k as well.

Adding the actual OpenWrt stakeholders. Is there any public hardware
platform that uses this yet?

Luis

2011-11-16 21:22:01

by Gabor Juhos

[permalink] [raw]
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

2011.11.15. 17:09 keltezéssel, Luis R. Rodriguez írta:
> On Tue, Nov 15, 2011 at 3:23 AM, Sangwook Lee <[email protected]> wrote:
>> The patch series proposes to rename ath9k_platform.h to "ath_platform.h
>> This header file handles platform data used only for ath9k,
>> but it can used by ath6k as well.
>
> Adding the actual OpenWrt stakeholders. Is there any public hardware
> platform that uses this yet?

It is used by the ath79 platform code in the mainline kernel, although only the
AP81 reference board uses that for now. However the linux-mips tree also has
code for the AP121 reference board, and that will use it as well.

Additionaly, we are using that in OpenWrt for several consumer boards which are
based on the AR71xx/AR724x/AR913x SoCs.

-Gabor

2011-11-15 16:44:30

by Kalle Valo

[permalink] [raw]
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

Hi Sangwook,

On 11/15/2011 01:23 PM, Sangwook Lee wrote:
> The patch series proposes to rename ath9k_platform.h to "ath_platform.h
> This header file handles platform data used only for ath9k,
> but it can used by ath6k as well. We can take "wl12xx.h" as
> as a example. Please let us change this file name so that
> other Atheors WLANs use this file for their own platform data

ath9k and ath6kl are very different devices, I'm not sure if sharing a
platfrom struct between the two is really a good idea. Most likely there
is very little the two drivers can share. What are your plans here?

I myself was thinking that we would have include/linux/ath6kl.h
dedicated just for ath6kl. That would makes things simpler.

Kalle

2011-11-17 19:07:02

by Kalle Valo

[permalink] [raw]
Subject: Re: [PATCH] ath9k: rename ath9k_platform.h to ath_platform.h

Hi Sangwook,

On 11/16/2011 01:34 PM, Sangwook Lee wrote:

>
> On 15 November 2011 16:37, Kalle Valo <[email protected]
> <mailto:[email protected]>> wrote:
>
> Hi Sangwook,
>
> On 11/15/2011 01:23 PM, Sangwook Lee wrote:
> > The patch series proposes to rename ath9k_platform.h to
> "ath_platform.h
> > This header file handles platform data used only for ath9k,
> > but it can used by ath6k as well. We can take "wl12xx.h" as
> > as a example. Please let us change this file name so that
> > other Atheors WLANs use this file for their own platform data
>
> ath9k and ath6kl are very different devices, I'm not sure if sharing a
> platfrom struct between the two is really a good idea. Most likely there
> is very little the two drivers can share. What are your plans here?
>
>
>
> As you know, if ath6kl is not SDIO powered (in most of cases, including
> mine)
> we need to use platform struct in order to control reset/power line,
> because ath6k is designed for mobile and embedded devices.

We have been actually planning to do the same, but it's still on our
todo list. If you can do this it would be awesome.

Also we need to provide some clock configuration from the board file and
I'm sure there will be more in the future. But let's start with the
power control.

> so I found out that there is already header file for ath9k's platform
> struct. How about using the one header file instead of
> "include/linux/ath9k_platform.h"
> , and "include/linux/ath6k_platform.h" ?
>
>
> I myself was thinking that we would have include/linux/ath6kl.h
> dedicated just for ath6kl. That would makes things simpler.
>
> But since I don't know much about ath9k, if you want to make the
> separate header file for ath6kl's own struct, It would be fine as well.

Yeah, I really would like to use separate file for ath6kl.

Kalle