2016-03-30 10:24:37

by Du, Changbin

[permalink] [raw]
Subject: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

From: "Du, Changbin" <[email protected]>

Actually, the function only clean one trb. So rename the function.

Signed-off-by: Du, Changbin <[email protected]>
---
drivers/usb/dwc3/gadget.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
index 3ac170f..f84be3d 100644
--- a/drivers/usb/dwc3/gadget.c
+++ b/drivers/usb/dwc3/gadget.c
@@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct dwc3 *dwc)

/* -------------------------------------------------------------------------- */

-static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep *dep,
+static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep *dep,
struct dwc3_request *req, struct dwc3_trb *trb,
const struct dwc3_event_depevt *event, int status)
{
@@ -1975,7 +1975,7 @@ static int dwc3_cleanup_done_reqs(struct dwc3 *dwc, struct dwc3_ep *dep,
slot %= DWC3_TRB_NUM;
trb = &dep->trb_pool[slot];

- ret = __dwc3_cleanup_done_trbs(dwc, dep, req, trb,
+ ret = __dwc3_cleanup_one_trb(dwc, dep, req, trb,
event, status);
if (ret)
break;
--
2.5.0


2016-03-30 10:59:18

by Felipe Balbi

[permalink] [raw]
Subject: Re: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb


Hi,

[email protected] writes:
> [ text/plain ]
> From: "Du, Changbin" <[email protected]>
>
> Actually, the function only clean one trb. So rename the function.
>
> Signed-off-by: Du, Changbin <[email protected]>

okay :-)

> ---
> drivers/usb/dwc3/gadget.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/dwc3/gadget.c b/drivers/usb/dwc3/gadget.c
> index 3ac170f..f84be3d 100644
> --- a/drivers/usb/dwc3/gadget.c
> +++ b/drivers/usb/dwc3/gadget.c
> @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct dwc3 *dwc)
>
> /* -------------------------------------------------------------------------- */
>
> -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep *dep,
> +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep *dep,

I would rather just remove that 's' from the end so the function's name
stays as __dwc3_cleanup_done_trb() ;-)

Care to do that ?

thanks

--
balbi


Attachments:
signature.asc (818.00 B)

2016-03-30 11:05:48

by Du, Changbin

[permalink] [raw]
Subject: RE: [PATCH] usb: dwc3: rename __dwc3_cleanup_done_trbs to __dwc3_cleanup_one_trb

> > @@ -1873,7 +1873,7 @@ static void dwc3_gadget_free_endpoints(struct
> dwc3 *dwc)
> >
> > /* -------------------------------------------------------------------------- */
> >
> > -static int __dwc3_cleanup_done_trbs(struct dwc3 *dwc, struct dwc3_ep
> *dep,
> > +static int __dwc3_cleanup_one_trb(struct dwc3 *dwc, struct dwc3_ep
> *dep,
>
> I would rather just remove that 's' from the end so the function's name
> stays as __dwc3_cleanup_done_trb() ;-)
>
> Care to do that ?
>
> thanks
>
> --
> Balbi

IMO, "one_trb" is a little more clear. But both is okay for me. :)

Thanks,
Du, Changbin