2020-11-12 07:12:36

by Luo Jiaxing

[permalink] [raw]
Subject: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
for read-only file, but we found many of drivers also want a helper macro
for read-write file too.

So we add this macro to help decrease code duplication.

---
v1->v2:
1.Rename DEFINE_STORE_ATTRIBUTE() to DEFINE_SHOW_STORE_ATTRIBUTE().
2.AI Viro points out that he doesn't like the definition of macros
like DEFINE_SHOW_ATTRIBUTE.
v2->v3:
1.Fixed some spelling mistakes in commit.
2.Revision description are added for easy tracing.

v3->v4:
1.Add AI Viro's comment to v1->v2's revision description.
2.Fixed a spelling mistakes of "marco" to "macro".
---

Luo Jiaxing (5):
seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs

.../gpu/drm/i915/display/intel_display_debugfs.c | 55 +--------
drivers/scsi/hisi_sas/hisi_sas_main.c | 135 +++------------------
drivers/scsi/qla2xxx/qla_dfs.c | 19 +--
drivers/usb/dwc3/debugfs.c | 52 +-------
include/linux/seq_file.h | 15 +++
5 files changed, 41 insertions(+), 235 deletions(-)

--
2.7.4


2023-06-28 10:56:48

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

On Thu, Nov 12, 2020 at 03:07:38PM +0800, Luo Jiaxing wrote:
> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
> for read-only file, but we found many of drivers also want a helper macro
> for read-write file too.
>
> So we add this macro to help decrease code duplication.

Is it abandoned?
Besides kbuildbot complains, can you simply reduce the scope to one subsystem
and resend?

Let's say USB is nice one and it has no issues according to kbuildbot.

--
With Best Regards,
Andy Shevchenko



2023-09-01 17:06:27

by yangxingui

[permalink] [raw]
Subject: Re: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c



On 2023/9/1 2:19, Andy Shevchenko wrote:
> On Thu, Nov 12, 2020 at 03:07:38PM +0800, Luo Jiaxing wrote:
>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
>> for read-only file, but we found many of drivers also want a helper macro
>> for read-write file too.
>>
>> So we add this macro to help decrease code duplication.
>
> Are you going to pursue this one?
Hi Andy

Jiaxing has left his job, and his email is invalid.

Thanks,
Xingui
>

2023-09-04 09:20:12

by yangxingui

[permalink] [raw]
Subject: Re: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c



On 2023/9/1 16:54, Andy Shevchenko wrote:
> On Fri, Sep 01, 2023 at 03:11:38PM +0800, yangxingui wrote:
>> On 2023/9/1 2:19, Andy Shevchenko wrote:
>>> On Thu, Nov 12, 2020 at 03:07:38PM +0800, Luo Jiaxing wrote:
>>>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
>>>> for read-only file, but we found many of drivers also want a helper macro
>>>> for read-write file too.
>>>>
>>>> So we add this macro to help decrease code duplication.
>>>
>>> Are you going to pursue this one?
>> Hi Andy
>>
>> Jiaxing has left his job, and his email is invalid.
>
> OK! Anybody else to continue this to be finished?
I'll continue to do this for him. Thank you for your attention and
advice. We'll apply it only to the scsi subsystem first.

Thanks.

Xingui
>

2023-09-05 16:21:11

by Andy Shevchenko

[permalink] [raw]
Subject: Re: [PATCH v4 0/5] Introduce a new helper macro DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c

On Thu, Nov 12, 2020 at 03:07:38PM +0800, Luo Jiaxing wrote:
> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
> for read-only file, but we found many of drivers also want a helper macro
> for read-write file too.
>
> So we add this macro to help decrease code duplication.

Are you going to pursue this one?

--
With Best Regards,
Andy Shevchenko