2021-11-04 06:19:38

by David Yang

[permalink] [raw]
Subject: [PATCH] powerpc: use swap() to make code cleaner

From: Yang Guang <[email protected]>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <[email protected]>
Signed-off-by: Yang Guang <[email protected]>
---
arch/powerpc/kernel/fadump.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/arch/powerpc/kernel/fadump.c b/arch/powerpc/kernel/fadump.c
index b7ceb041743c..5b40e2d46090 100644
--- a/arch/powerpc/kernel/fadump.c
+++ b/arch/powerpc/kernel/fadump.c
@@ -1265,7 +1265,6 @@ static void fadump_release_reserved_area(u64 start, u64 end)
static void sort_and_merge_mem_ranges(struct fadump_mrange_info *mrange_info)
{
struct fadump_memory_range *mem_ranges;
- struct fadump_memory_range tmp_range;
u64 base, size;
int i, j, idx;

@@ -1281,9 +1280,7 @@ static void sort_and_merge_mem_ranges(struct fadump_mrange_info *mrange_info)
idx = j;
}
if (idx != i) {
- tmp_range = mem_ranges[idx];
- mem_ranges[idx] = mem_ranges[i];
- mem_ranges[i] = tmp_range;
+ swap(mem_ranges[idx], mem_ranges[i]);
}
}

--
2.30.2


2021-11-04 10:09:19

by Stephen Rothwell

[permalink] [raw]
Subject: Re: [PATCH] powerpc: use swap() to make code cleaner

Hi,

On Thu, 4 Nov 2021 14:17:09 +0800 [email protected] wrote:
>
> From: Yang Guang <[email protected]>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.

So if swap() is in the above include file, then you should include it.

--
Cheers,
Stephen Rothwell


Attachments:
(No filename) (499.00 B)
OpenPGP digital signature

2021-11-04 11:42:48

by Segher Boessenkool

[permalink] [raw]
Subject: Re: [PATCH] powerpc: use swap() to make code cleaner

On Thu, Nov 04, 2021 at 09:06:56PM +1100, Stephen Rothwell wrote:
> On Thu, 4 Nov 2021 14:17:09 +0800 [email protected] wrote:
> > From: Yang Guang <[email protected]>
> >
> > Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> > opencoding it.
>
> So if swap() is in the above include file, then you should include it.

It is included from kernel.h already (which is included from delay.h).


Segher

2021-11-04 21:05:25

by Stephen Rothwell

[permalink] [raw]
Subject: Re: [PATCH] powerpc: use swap() to make code cleaner

Hi Segher,

On Thu, 4 Nov 2021 06:33:51 -0500 Segher Boessenkool <[email protected]> wrote:
>
> On Thu, Nov 04, 2021 at 09:06:56PM +1100, Stephen Rothwell wrote:
> > On Thu, 4 Nov 2021 14:17:09 +0800 [email protected] wrote:
> > > From: Yang Guang <[email protected]>
> > >
> > > Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> > > opencoding it.
> >
> > So if swap() is in the above include file, then you should include it.
>
> It is included from kernel.h already (which is included from delay.h).

And that becomes a pain when include files get "cleaned up". :-(

$ grep kernel.h include/linux/delay.h
$

See commit

300424acf349 ("include/linux/delay.h: replace kernel.h with the necessary inclusions")

currently pending the Andrew Morton's patch queue (the above is a
linux-next commit).
--
Cheers,
Stephen Rothwell


Attachments:
(No filename) (499.00 B)
OpenPGP digital signature