2018-10-16 13:43:47

by Tomas Winkler

[permalink] [raw]
Subject: [PATCH] tpm: tpm_try_transmit() refactor error flow.

First, rename out_no_locality to out_locality for bailing out on
both tpm_cmd_ready() and tpm_request_locality() failure.
Second, ignore the return value of go_to_idle() as it may override
the return value of the actual tpm operation, the go_to_idle() error
will be caught on any consequent command.
Last, fix the wrong 'goto out', that jumped back instead of forward.

Cc: [email protected]
Fixes: 627448e85c76 ("tpm: separate cmd_ready/go_idle from runtime_pm")
Signed-off-by: Tomas Winkler <[email protected]>
---
drivers/char/tpm/tpm-interface.c | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

diff --git a/drivers/char/tpm/tpm-interface.c b/drivers/char/tpm/tpm-interface.c
index 129f640424b7..95db630dd722 100644
--- a/drivers/char/tpm/tpm-interface.c
+++ b/drivers/char/tpm/tpm-interface.c
@@ -477,13 +477,15 @@ static ssize_t tpm_try_transmit(struct tpm_chip *chip,

if (need_locality) {
rc = tpm_request_locality(chip, flags);
- if (rc < 0)
- goto out_no_locality;
+ if (rc < 0) {
+ need_locality = false;
+ goto out_locality;
+ }
}

rc = tpm_cmd_ready(chip, flags);
if (rc)
- goto out;
+ goto out_locality;

rc = tpm2_prepare_space(chip, space, ordinal, buf);
if (rc)
@@ -547,14 +549,13 @@ static ssize_t tpm_try_transmit(struct tpm_chip *chip,
dev_err(&chip->dev, "tpm2_commit_space: error %d\n", rc);

out:
- rc = tpm_go_idle(chip, flags);
- if (rc)
- goto out;
+ /* may fail but do not override previous error value in rc */
+ tpm_go_idle(chip, flags);

+out_locality:
if (need_locality)
tpm_relinquish_locality(chip, flags);

-out_no_locality:
if (chip->ops->clk_enable != NULL)
chip->ops->clk_enable(chip, false);

--
2.14.4



2018-10-18 00:15:43

by Jarkko Sakkinen

[permalink] [raw]
Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.

On Tue, 16 Oct 2018, Tomas Winkler wrote:
> First, rename out_no_locality to out_locality for bailing out on
> both tpm_cmd_ready() and tpm_request_locality() failure.

This is unnecessary change and technically it is not a rename: the
commit message text and the code change do not match. Rename is just a
rename (i.e. change a variable name foo to bar).

/Jarkko

2018-10-18 06:07:08

by Tomas Winkler

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.



> -----Original Message-----
> From: Jarkko Sakkinen [mailto:[email protected]]
> Sent: Thursday, October 18, 2018 03:15
> To: Winkler, Tomas <[email protected]>
> Cc: Jarkko Sakkinen <[email protected]>; Jason Gunthorpe
> <[email protected]>; Nayna Jain <[email protected]>; Usyskin,
> Alexander <[email protected]>; Struk, Tadeusz
> <[email protected]>; [email protected]; linux-security-
> [email protected]; [email protected];
> [email protected]
> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
>
> On Tue, 16 Oct 2018, Tomas Winkler wrote:
> > First, rename out_no_locality to out_locality for bailing out on both
> > tpm_cmd_ready() and tpm_request_locality() failure.
>
> This is unnecessary change and technically it is not a rename: the commit
> message text and the code change do not match. Rename is just a rename
> (i.e. change a variable name foo to bar).

I'm renaming the label because it doesn't match the code flow anymore,
I can change the commit message, but you please review the code.
Tomas





2018-10-19 23:35:10

by Jarkko Sakkinen

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

On Thu, 18 Oct 2018, Winkler, Tomas wrote:
>> -----Original Message-----
>> From: Jarkko Sakkinen [mailto:[email protected]]
>> Sent: Thursday, October 18, 2018 03:15
>> To: Winkler, Tomas <[email protected]>
>> Cc: Jarkko Sakkinen <[email protected]>; Jason Gunthorpe
>> <[email protected]>; Nayna Jain <[email protected]>; Usyskin,
>> Alexander <[email protected]>; Struk, Tadeusz
>> <[email protected]>; [email protected]; linux-security-
>> [email protected]; [email protected];
>> [email protected]
>> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
>>
>> On Tue, 16 Oct 2018, Tomas Winkler wrote:
>>> First, rename out_no_locality to out_locality for bailing out on both
>>> tpm_cmd_ready() and tpm_request_locality() failure.
>>
>> This is unnecessary change and technically it is not a rename: the commit
>> message text and the code change do not match. Rename is just a rename
>> (i.e. change a variable name foo to bar).
>
> I'm renaming the label because it doesn't match the code flow anymore,
> I can change the commit message, but you please review the code.
> Tomas

The flow change is unnecessary and does not really have anything to do
with the bug fix. Earlier version was better than this and would have
been fine when taking account the remark from Jason.

/Jarkko

2018-10-20 22:50:26

by Tomas Winkler

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

>
> On Thu, 18 Oct 2018, Winkler, Tomas wrote:
> >> -----Original Message-----
> >> From: Jarkko Sakkinen [mailto:[email protected]]
> >> Sent: Thursday, October 18, 2018 03:15
> >> To: Winkler, Tomas <[email protected]>
> >> Cc: Jarkko Sakkinen <[email protected]>; Jason
> >> Gunthorpe <[email protected]>; Nayna Jain <[email protected]>;
> >> Usyskin, Alexander <[email protected]>; Struk, Tadeusz
> >> <[email protected]>; [email protected];
> >> linux-security- [email protected]; [email protected];
> >> [email protected]
> >> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
> >>
> >> On Tue, 16 Oct 2018, Tomas Winkler wrote:
> >>> First, rename out_no_locality to out_locality for bailing out on
> >>> both
> >>> tpm_cmd_ready() and tpm_request_locality() failure.
> >>
> >> This is unnecessary change and technically it is not a rename: the
> >> commit message text and the code change do not match. Rename is just
> >> a rename (i.e. change a variable name foo to bar).
> >
> > I'm renaming the label because it doesn't match the code flow anymore,
> > I can change the commit message, but you please review the code.
> > Tomas
>
> The flow change is unnecessary and does not really have anything to do with
> the bug fix.

What I see in the original code is that when
tpm_cmd_ready() fails it's jumps to 'out' label and trying to do tpm_go_idle()
but instead it should just undoing the locality, so both cmd_read and go idle had a wrong
jump. I see both should be fixed.

Earlier version was better than this and would have been fine
> when taking account the remark from Jason.


2018-10-23 13:30:17

by Jarkko Sakkinen

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.



On Sat, 20 Oct 2018, Winkler, Tomas wrote:

>>
>> On Thu, 18 Oct 2018, Winkler, Tomas wrote:
>>>> -----Original Message-----
>>>> From: Jarkko Sakkinen [mailto:[email protected]]
>>>> Sent: Thursday, October 18, 2018 03:15
>>>> To: Winkler, Tomas <[email protected]>
>>>> Cc: Jarkko Sakkinen <[email protected]>; Jason
>>>> Gunthorpe <[email protected]>; Nayna Jain <[email protected]>;
>>>> Usyskin, Alexander <[email protected]>; Struk, Tadeusz
>>>> <[email protected]>; [email protected];
>>>> linux-security- [email protected]; [email protected];
>>>> [email protected]
>>>> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
>>>>
>>>> On Tue, 16 Oct 2018, Tomas Winkler wrote:
>>>>> First, rename out_no_locality to out_locality for bailing out on
>>>>> both
>>>>> tpm_cmd_ready() and tpm_request_locality() failure.
>>>>
>>>> This is unnecessary change and technically it is not a rename: the
>>>> commit message text and the code change do not match. Rename is just
>>>> a rename (i.e. change a variable name foo to bar).
>>>
>>> I'm renaming the label because it doesn't match the code flow anymore,
>>> I can change the commit message, but you please review the code.
>>> Tomas
>>
>> The flow change is unnecessary and does not really have anything to do with
>> the bug fix.
>
> What I see in the original code is that when
> tpm_cmd_ready() fails it's jumps to 'out' label and trying to do tpm_go_idle()
> but instead it should just undoing the locality, so both cmd_read and go idle had a wrong
> jump. I see both should be fixed.
>
> Earlier version was better than this and would have been fine
>> when taking account the remark from Jason.

So you are doing tpm_cmd_ready() change in order to prevent unnecessary
call to tpm_go_idle() that was previously i.e. before when that function
failed in jumped to out and called tpm_go_idle()?

This should be probably split into two commits if I understood right. You
did not have this updated mentioned in a changelog (there was no
changelog).

Have you checked that if these were separate commits they would have the
same fixes line? Why not use the label name 'out' as the same label
handles bot 'locality' and 'no_locality'?


/Jarkko

2018-10-23 14:18:28

by Tomas Winkler

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

>
>
> On Sat, 20 Oct 2018, Winkler, Tomas wrote:
>
> >>
> >> On Thu, 18 Oct 2018, Winkler, Tomas wrote:
> >>>> -----Original Message-----
> >>>> From: Jarkko Sakkinen [mailto:[email protected]]
> >>>> Sent: Thursday, October 18, 2018 03:15
> >>>> To: Winkler, Tomas <[email protected]>
> >>>> Cc: Jarkko Sakkinen <[email protected]>; Jason
> >>>> Gunthorpe <[email protected]>; Nayna Jain <[email protected]>;
> >>>> Usyskin, Alexander <[email protected]>; Struk, Tadeusz
> >>>> <[email protected]>; [email protected];
> >>>> linux-security- [email protected];
> >>>> [email protected]; [email protected]
> >>>> Subject: Re: [PATCH] tpm: tpm_try_transmit() refactor error flow.
> >>>>
bb> >>>> On Tue, 16 Oct 2018, Tomas Winkler wrote:
> >>>>> First, rename out_no_locality to out_locality for bailing out on
> >>>>> both
> >>>>> tpm_cmd_ready() and tpm_request_locality() failure.
> >>>>
> >>>> This is unnecessary change and technically it is not a rename: the
> >>>> commit message text and the code change do not match. Rename is
> >>>> just a rename (i.e. change a variable name foo to bar).
> >>>
> >>> I'm renaming the label because it doesn't match the code flow
> >>> anymore, I can change the commit message, but you please review the
> code.
> >>> Tomas
> >>
> >> The flow change is unnecessary and does not really have anything to
> >> do with the bug fix.
> >
> > What I see in the original code is that when
> > tpm_cmd_ready() fails it's jumps to 'out' label and trying to do
> > tpm_go_idle() but instead it should just undoing the locality, so both
> > cmd_read and go idle had a wrong jump. I see both should be fixed.
> >
> > Earlier version was better than this and would have been fine
> >> when taking account the remark from Jason.
>
> So you are doing tpm_cmd_ready() change in order to prevent unnecessary
> call to tpm_go_idle() that was previously i.e. before when that function
> failed in jumped to out and called tpm_go_idle()?

>
> This should be probably split into two commits if I understood right. You did
> not have this updated mentioned in a changelog (there was no changelog).

I'm not sure why to do it in two steps, this addresses the same issue.

> Have you checked that if these were separate commits they would have the
> same fixes line? Why not use the label name 'out' as the same label handles
> bot 'locality' and 'no_locality'?

To the out label we jump after we are done with locality and cmd read() before we jump to locality 'locality'.
We will need to add another variable to check If cmd_ready() was called or not in order to get rid of the extran label,
it's not internally tracked so far.
I'm not sure what is better, I prefer this short fix, as the transmit() has to be rewritten anyway at some point, the recursion what is there is not helthy.

Thanks
Tomas


2018-10-24 09:00:45

by Jarkko Sakkinen

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

On Tue, 23 Oct 2018, Winkler, Tomas wrote:
> To the out label we jump after we are done with locality and cmd
> read() before we jump to locality 'locality'. We will need to add
> another variable to check If cmd_ready() was called or not in order to
> get rid of the extran label, it's not internally tracked so far.

I think this is fine.

Reviewed-by: Jarkko Sakkinen <[email protected]>
Tested-by: Jarkko Sakkinen <[email protected]>

I tested this by assigning rc error code instead of requesting locality
in addition of testig unchanged code.

/Jarkko

2018-10-24 09:02:11

by Tomas Winkler

[permalink] [raw]
Subject: RE: [PATCH] tpm: tpm_try_transmit() refactor error flow.

>
> On Tue, 23 Oct 2018, Winkler, Tomas wrote:
> > To the out label we jump after we are done with locality and cmd
> > read() before we jump to locality 'locality'. We will need to add
> > another variable to check If cmd_ready() was called or not in order to
> > get rid of the extran label, it's not internally tracked so far.
>
> I think this is fine.
>
> Reviewed-by: Jarkko Sakkinen <[email protected]>
> Tested-by: Jarkko Sakkinen <[email protected]>
>
> I tested this by assigning rc error code instead of requesting locality in
> addition of testig unchanged code.
>
Great
Thanks
Tomas